D16461: Fix syntax support for dynamic member access.
Kevin Funk
noreply at phabricator.kde.org
Fri Nov 16 14:14:45 GMT 2018
kfunk added a comment.
I wonder if a couple of `auto* element = it->element`, `auto* staticProperty = it->element->staticProperty` sprayed throughout the code base would help making all of this a bit more readable...
INLINE COMMENTS
> uses.cpp:1423
> + QCOMPARE(dec->identifier(), Identifier("a"));
> + compareUses(dec, QList<RangeInRevision>()
> + << RangeInRevision(3, 9, 3, 10));
Minor, for future: you can use C++11-style initialization here: `QList<RangeInRevision>{...}`
More TODO: Should be a `QVector<RangeInRevision>` for performance reasons.
REPOSITORY
R52 KDevelop: PHP Support
REVISION DETAIL
https://phabricator.kde.org/D16461
To: pprkut, kfunk
Cc: kfunk, kdevelop-devel, glebaccon, antismap, iodelay, vbspam, geetamc, Pilzschaf, akshaydeo, surgenight, arrowd
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kdevelop-devel/attachments/20181116/11d8ddc9/attachment.html>
More information about the KDevelop-devel
mailing list