[Differential] [Accepted] D3477: Miscellaneous helper cleanups

brauch (Sven Brauch) noreply at phabricator.kde.org
Thu Nov 24 19:17:53 UTC 2016


brauch accepted this revision.
brauch added a comment.
This revision is now accepted and ready to land.


  Looks good thanks.

INLINE COMMENTS

> expressionvisitor.cpp:386
>              DUChainReadLocker lock;
> -            Declaration* function = Helper::accessAttribute(type, "__getitem__", context());
> +            static const IndexedIdentifier initIdentifier(KDevelop::Identifier("__getitem__"));
> +            Declaration* function = Helper::accessAttribute(type, initIdentifier, topContext());

bad variable name

> expressionvisitor.cpp:387
> +            static const IndexedIdentifier initIdentifier(KDevelop::Identifier("__getitem__"));
> +            Declaration* function = Helper::accessAttribute(type, initIdentifier, topContext());
>              if ( function && function->isFunctionDeclaration() ) {

if we're cleaning up already, make this an auto too.

> helpers.cpp:230
> +    if ( auto classDecl = dynamic_cast<ClassDeclaration*>(decl) ) {
> +        FOREACH_FUNCTION ( const BaseClassInstance& base, classDecl->baseClasses ) {
>              if ( flags == PublicOnly && base.access == KDevelop::Declaration::Private ) {

auto here too if you touch this anyways

REPOSITORY
  rKDEVPYTHON KDev-python

REVISION DETAIL
  https://phabricator.kde.org/D3477

EMAIL PREFERENCES
  https://phabricator.kde.org/settings/panel/emailpreferences/

To: flherne, brauch
Cc: kdevelop-devel
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kdevelop-devel/attachments/20161124/772a5a56/attachment.html>


More information about the KDevelop-devel mailing list