KDevelop KF5 how to

Sergey Kalinichev kalinichev.so.0 at gmail.com
Sun Jun 22 09:03:53 UTC 2014

Hi everyone!

I noticed the discussion about switching to the KF5 soon, so I decided
to try it out myself.

Here are the problems that I've encountered:

1.  This is not exactly the KDevelop's isuue still it prevents it's building:
The ECMGenerateHeaders.cmake doesn't always generate the CamelCase headers:
    HEADER_NAMES KSharedDataCache
    RELATIVE caching

E.g. in the case above it won't. To reproduce it try to install the
KCoreAddons (but first remove already installed CamelCase headers, if
you have any) and see if they will be generated once again.

2. And the second and what is more important the KDevelop won't
launch. It immediately crashes, without even reaching the main
 Please note that all other apps from the KDE frameworks branch launch
just fine (I've tried Kate, Konsole and Dolphin )

The backtrace:
#0  0x00007fffeaa3c90c in ?? ()
   from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#1  0x00007ffff7deaa2a in call_init (l=<optimized out>,
    argc=argc at entry=1, argv=argv at entry=0x7fffffffdaf8,
    env=env at entry=0x7fffffffdb08) at dl-init.c:78
#2  0x00007ffff7deab13 in call_init (env=0x7fffffffdb08,
    argv=0x7fffffffdaf8, argc=1, l=<optimized out>) at dl-init.c:36
#3  _dl_init (main_map=0x7ffff7ffe1a8, argc=1, argv=0x7fffffffdaf8,
    env=0x7fffffffdb08) at dl-init.c:126
#4  0x00007ffff7ddd1ca in _dl_start_user ()
   from /lib64/ld-linux-x86-64.so.2
#5  0x0000000000000001 in ?? ()
#6  0x00007fffffffdea8 in ?? ()
#7  0x0000000000000000 in ?? ()

So I'm wondering if anyone have actually tried it, if so what am I
doing wrong then?


More information about the KDevelop-devel mailing list