Review Request 114323: Clean up session description handling.
Milian Wolff
mail at milianw.de
Thu Dec 12 15:53:58 UTC 2013
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://git.reviewboard.kde.org/r/114323/#review45608
-----------------------------------------------------------
Ship it!
Jup, looks nice. One small cleanup then feel free to commit!
Thanks
shell/session.cpp
<http://git.reviewboard.kde.org/r/114323/#comment32549>
group(QString()), and maybe put this group into a named variable and reuse it below
shell/session.cpp
<http://git.reviewboard.kde.org/r/114323/#comment32548>
group( QString() )
- Milian Wolff
On Dec. 12, 2013, 3:20 p.m., Ivan Shapovalov wrote:
>
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> http://git.reviewboard.kde.org/r/114323/
> -----------------------------------------------------------
>
> (Updated Dec. 12, 2013, 3:20 p.m.)
>
>
> Review request for KDevelop.
>
>
> Repository: kdevplatform
>
>
> Description
> -------
>
> This fixes session list and window title not reflecting actual session data (name and project list).
>
> Things done:
> 1) project list is written to the session via a new interface method (ISession::setContainedProjects()) instead of directly writing to the session's config
> 2) signal Session::nameChanged() is replaced by Session::sessionUpdated(), which is called on both name change and project list change
> 3) anything that displays session contents now listens only to that signal instead of nameChanged()+projectOpened()+projectClosed()
>
>
> Diffs
> -----
>
> interfaces/isession.h d96695d
> shell/mainwindow.cpp ddb07f5
> shell/projectcontroller.cpp ee89dd7
> shell/session.h 0154156
> shell/session.cpp 9fdd31f
> shell/sessioncontroller.h 1986360
> shell/sessioncontroller.cpp 3be453e
> shell/tests/sessioncontrollertest.cpp d7e9093
>
> Diff: http://git.reviewboard.kde.org/r/114323/diff/
>
>
> Testing
> -------
>
> Works as expected and unit-tests pass.
>
>
> Thanks,
>
> Ivan Shapovalov
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kdevelop-devel/attachments/20131212/e7293f77/attachment.html>
More information about the KDevelop-devel
mailing list