Review Request 112039: Add a CPU registers view.

Milian Wolff mail at milianw.de
Tue Aug 20 20:51:41 UTC 2013


On Monday 19 August 2013 17:49:01 Vlas Puhov wrote:
> > On Aug. 16, 2013, 11:22 a.m., Milian Wolff wrote:
> > > debuggers/gdb/registers/registercontroller.h, line 50
> > > <http://git.reviewboard.kde.org/r/112039/diff/1/?file=178355#file178355l
> > > ine50>> > 
> > >     remove these two constructors, use
> > >     
> > >     Register foo = { foo, value };
> > >     
> > >     To achieve what you want.
> 
> I don't know, IMO:
> doSomething(Register (name, value));
> is more readable and consumes less space than
> Register r = {name, value};
> doSomething( r );

fair enough. /me needs to enable C++11 for KDevelop, then we wouldn't have 
that discussion :]

doSomething({name, value});

> > On Aug. 16, 2013, 11:22 a.m., Milian Wolff wrote:
> > > debuggers/gdb/registers/registercontroller.cpp, line 96
> > > <http://git.reviewboard.kde.org/r/112039/diff/1/?file=178356#file178356l
> > > ine96>> > 
> > >     quite a lot of debug output, is that still required and useful?
> 
> Well... debug output is always useful.
> It won't be in release version anyway. And it's shown only when registers
> toolview is active. Ok, maybe it was a little bit too much, so I've removed
> some.

Yes, useful debug output is useful :) But output like "doStuff" is seldomly 
useful. And note that kdebug output is not completely compiled out in release 
mode.

> > On Aug. 16, 2013, 11:22 a.m., Milian Wolff wrote:
> > > debuggers/gdb/registers/registercontroller.cpp, line 164
> > > <http://git.reviewboard.kde.org/r/112039/diff/1/?file=178356#file178356l
> > > ine164>> > 
> > >     foreach
> 
> I'd love to. But QT's foreach doesn't support references. Should I use c++11
> foreach, or BOOST's then?

Ah no, that was something I missed. Feel free to continue with the for-loops 
for now, until we finally enable c++11.

Thanks!
-- 
Milian Wolff
mail at milianw.de
http://milianw.de


More information about the KDevelop-devel mailing list