Git Support ready-ness

Andreas Pakulat apaku at
Mon Sep 6 06:30:38 UTC 2010

On 06.09.10 02:37:05, Aleix Pol wrote:
> On Sun, Sep 5, 2010 at 5:17 PM, David Nolden <zwabel at> wrote:
> > About the Git menu entries again:
> > - I find the "Update" menu entry confusing. Seems like it does the
> > same as "Pull", but there is also a "Pull" entry, so the "Update"
> > entry should disappear.
> >
> I agree, but I'm not sure if we should go deeper, maybe we could consider
> pull a type of update or something like that.

Pull is the git equivalent of svn update (roughly). But having both is
indeed not really good. So one has to go. Ideally I wanted to have
common actions (among all vcs) named similarly in all menus. So the
question is why was Pull added at all, when Update was already there...
And maybe Update is not the best text, how about "Update from

> > - Also the "Revision History" entry does nothing at all here, and
> > since there's "History", "Revision History" should also be removed.
> >
> It doesn't do anything because you #if 0'd the slot, I'm not sure why. It
> does something and it looks ugly, as I said we should review that and
> probably refactor the code inside the git plguin instead of vcs/dvcs but i
> think it's still usefull to see the branch history.

Why was "History" added in the first place? I'm guessing this is for
seeing the history of all branches? I'd suggest to enhance the standard
revision history with the ability to show history of multiple branches,
after all git is not the only tool that supports branches better than
svn. Maybe not for 4.1 (and just remove the non-working item), but
definetly later on.

> > - Also the "Compare to Base" and "Compare to Head" entries are quite
> > annoying, as I simply don't know what the difference between them is,
> > and user also won't get it. "Compare to Head" should IMO go away, and
> > maybe "Compare to Base" should be changed to "Local Changes..." or
> > something like that. However since those changes can also be inspected
> > when pushing "Commit...", maybe that entry could also go.
> >
> I agree, Andreas any thought about that? (I'm asking because I think you
> added that)

I didn't really add that, IIRC (it was there before done by the person
who ported the svn plugin). Anyway, personally I almost always use 'diff
to base', i.e. 'show local changes'. For git however this should be 'git
diff', _not_ 'git diff --staged'. The staged-diff should get a separate
entry at some point.

> > - Since "Push..." and "Pull..." always operate on the whole
> > repository, I think those should only be shown in the context-menu of
> > the whole repository. The same is probably true for the stash- and
> > branch-entries
> >
> Meh... I thought about that too... but putting it there i think it would
> make these features a little harder to find.

I disagree with David. Git also allows to do repository-operations in
any subdir and we're allowing to open the project configuration from the
context menu of any subdir too. Its a matter of convenience when having
a bigger project tree opened up to not have to scroll to the top to
create a new branch...

> > - "Push..." and "Pull..." are misleading, as their name suggests that
> > there will be a menu (due to the "..."), but at least for "Pull" there
> > is none.
> >
> Agreed

IMHO we should remove Pull... for now until we do have a dialog that
supports more than just the plain simple 'git pull' (i.e. pulling
directly from a remote, pulling specific refspecs) and replace it with
the 'Update' as I said above.


Excellent day for putting Slinkies on an escalator.

More information about the KDevelop-devel mailing list