KSharedPtr DUChainBase::weakPointer -> QWeakPointer?
David Nolden
zwabel at googlemail.com
Wed Jan 20 00:27:57 UTC 2010
Am Mittwoch 20 Januar 2010 00:14:17 schrieb Milian Wolff:
> Hey all!
>
> Shouldn't DUChainBase::weakPointer be a QWeakPointer instead of a
> KSharedPtr? Just asking because the name suggests it. And yes, I know
> QWeakPointer is new, but we depent on Qt 4.5 nowadays, so why not take
> advantage of it?
The duchain has an already-working and efficient scheme for weak references to
duchain objects, and I don't see a reason to do modifications to it.
QWeakPointer is something completely different than KSharedPtr, and anything
else but a drop-in replacement. So using QWeakPointer would require a lot of
needless changes. If anything, it could replace DUChainPointer, but before you
start doing something, you should define what issue you want to solve, and I
don't see an issue here...
Greetings, David
More information about the KDevelop-devel
mailing list