support for remote projects (fish / ftp / etc.)

Milian Wolff mail at milianw.de
Wed Mar 25 19:19:03 UTC 2009


On Tuesday 24 March 2009, Andreas Pakulat wrote:
> On 24.03.09 21:29:20, Milian Wolff wrote:
> > I just tried to create a remote project via fish and it did not work.
>
> No wonder :)
>
> > One problem I spotted and  -potentially- fixed is the initial project
> > creation.
>
> See comments below, after fixing that and removing debug output feel
> free to commit.
>
> > What I don't understand is the following: The project is listed as
> > "folder.kdev4" in the projects view. No files in that folder are shown.
>
> I don't think we currently have any project plugin that supports remote
> urls. I assume you've used the generic project manager? That one only
> works on local files (AFAIK). So you'd need to start with that one and
> check what needs to be done to make it remote-ready.
>
> > The above would be required for Quanta sometime. Does the Duchain work
> > with remote projects?
>
> Yes, its also based on urls, even though they're converted into
> indexed-strings, but the strings are created via KUrl::url(). However
> existing C++ parser, cmake and qmake support don't support remote
> projects.

See my other mail.

> > +        // we have to cope the KUrl before and then jumps through some
> > hoops +        // if we don't want to loose protocol information
> > (required for remote projects)
>
> That comment is a bit hard to understand IMHO. Just say that directory()
> returns only a directory but for remote-project we need the full url
> info.

True. I will change the comment if the patch will be incorporated. See my 
other mail for more on that topic.

> >          statJob = KIO::stat( developerFileUrl, KIO::HideProgressInfo );
> >          if( !statJob->exec() )
> >          {
> > -            KUrl dir = KUrl( projectFileUrl.directory(
> > KUrl::AppendTrailingSlash ) + ".kdev4"); +            KUrl dir =
> > projectFileUrl;
> > +            dir.setPath( dir.directory( KUrl::AppendTrailingSlash ) +
> > ".kdev4" );
>
> You could use dir.addPath( ".kdev4" ) instead here.

Just ported the old code here. But yes, I could use addPath - would be 
basically the same, just a line more, maybe a bit more readable.

-- 
Milian Wolff
mail at milianw.de
http://milianw.de
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 197 bytes
Desc: This is a digitally signed message part.
URL: <http://mail.kde.org/pipermail/kdevelop-devel/attachments/20090325/b203a7ec/attachment.sig>


More information about the KDevelop-devel mailing list