Namespacing in kdevelop/lib
jpetso at gmx.at
Wed Jul 19 10:22:01 UTC 2006
On Wednesday, 19. July 2006 09:50, Andras Mantia wrote:
> But if you anyway want to namespace it, call simply KDevelop. Calling it
> "KDev" doesn't bring any extra readability (even now all classes start
> that way), KDevPlatform is also a cryptic name, KDevelopPlatform might
> be good, but it is long.
I'm not against namespacing, and I agree with the above reasoning,
so count another vote for KDevelop::Xyz.
I do hope that people won't be "using namespace KDevelop;" when it
hurts readability. I think the KDevelop hackers are be knowledgable enough
to care about that.
More information about the KDevelop-devel