KDevelop4 API questions
jpetso at gmx.at
Thu Aug 17 08:30:40 UTC 2006
On Thursday, 17. August 2006 08:36, Andras Mantia wrote:
> On Thursday 17 August 2006 04:14, Adam Treat wrote:
> > Please don't. I know I need to document them, but they do have a
> > purpose...
> > projectDirectory == the dir where the current project file is
> > located.
> > projectsDirectory == the dir where the user holds all of his project
> > folders ... perhaps this can be renamed to better illustrate 100what it
> > is.
> Yes, this is what I imagined. To avoid confusion this is why I suggest
> renaming the methods:
> - projectDirectory => projectFileDirectory or globalFileDirectory, as in
> the API the project file is called global file
> - projectsDirectory => projectDirectory. I'm not a native speaker and I
> could imagine the name comes from "project's directory", but I find it
I find this more confusing than the original version.
For me, it's much more logical to have a distinction
1. where the current project is
2. where the projectS are, usually (not always)
The s in projects is really a plural, doesn't relate to the genitive at all.
Maybe something like currentProjectDirectory and defaultProjectDirectory?
Just my 2 cent,
More information about the KDevelop-devel