Debugger UI terminology
ghost at cs.msu.su
Thu Aug 18 15:25:26 UTC 2005
At the moment, the debugger UI uses "watch" in two different meanings.
- In the variables widget, there's "Watch" section. Expressions there
are reevaluated after each step.
- The breakpoint widget, and the popup menu in the variables widget, uses
"Watchpoint" -- that is "breakpoint on value change"
I think that those two meaning might well confuse users, especially when they
appear in the same popup menu:
There's both "Watch variable" and "Toggle watchpoint" items.
I think that even renaming "Toggle watchpoint" to "Toggle breakpoint" will be
an improvement. Any comments?
More information about the KDevelop-devel