mattr at kde.org
Mon Nov 1 17:48:03 UTC 2004
On Mon, Nov 01, 2004 at 04:05:49PM +0000, Richard Dale wrote:
> On Monday 01 November 2004 13:26, Matt Rogers wrote:
> > On Monday 01 November 2004 02:25 am, Richard Dale wrote:
> > > On Monday 01 November 2004 05:07, Matt Rogers wrote:
> > > > Hi,
> > > >
> > > > Attached is a patch which changes the d pointer in the KDevApi class
> > > > not to use the m_ prefix for members of the d pointer. Since this is
> > > > somewhat of a style issue, I'd prefer to have the patch approved rather
> > > > than forcing my coding style on a file I only looked through to see if
> > > > it needed documenting.
> > >
> > > The 'm_' prefix naming convention is in common use in the KDE project,
> > > and I haven't read anyone saying that its use was deprecated.
> > >
> > > -- Richard
> > True, but i've found that it's not common to prefix variables with 'm_' if
> > they're in the d pointer, which these are.
> Surely it matters even less if they're in a private class? I don't see what
> problem you're trying to solve here.
I'm not trying to solve a problem per se, just do something that makes
the code easier to read, IMHO. I'm not going to force my coding style on
everybody else (unless it's my project, of course. ;) ) so I'll just
More information about the KDevelop-devel