Bug#46721: marked as done (SuSE 8, KDevelop & Qt Designer - packages mess) by Harald Fernengel <harry at kdevelop.org>

Stephan Kulow owner at bugs.kde.org
Wed Aug 21 22:36:13 UTC 2002

Your message with subj: Not a KDevelop bug


your Qt versions are somehow messed up, please remove all Qt2 rpm's and=20
completely reinstall Qt 3.0.5 from SuSE RPMs. If it still doesn't work,=20
please ask the SuSE support what might go wrong...

Best regards,

has caused the attached bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I'm
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Stephan Kulow
(administrator, KDE bugs database)

(Complete bug history is available at http://bugs.kde.org/db/46/46721.html)

Received: (at submit) by bugs.kde.org; 21 Aug 2002 07:20:27 +0000
Received: (qmail 7932 invoked by uid 30); 21 Aug 2002 07:20:26 -0000
Date: 21 Aug 2002 07:20:26 -0000
Message-ID: <20020821072026.7931.qmail at ktown.kde.org>
To: submit at bugs.kde.org
Subject: SuSE 8, KDevelop & Qt Designer - packages mess
From: lvanek at eanet.cz
X-KDE-Received: -

Package:           kdevelop
Version:           2.1.3 (using KDE 3.0.3 )
Severity:          normal
Installed from:    SuSE
Compiler:          gcc version 2.95.3 20010315 (SuSE)
OS:                Linux (i686) release 2.4.18-4GB
OS/Compiler notes: 

SuSE 8, fresh installation.

I tried to create dialog in KDevelop 2.1 with standart way - I created dlgname.ui file using File -> New....

1) I got question about loading ASCII file. I pressed NO
2) Dialog with question about program to open UI files. I typed "designer"
3) KDevelop started yast and yast installed qt-designer package. If I cancel this step, KDevelop doesn't start Qt Designer.  

But WHY KDevelop needs qt-designer package ??? qt-designer.rpm package contain old Qt2 designer and it is in conflict with  qt-devel-tools.rpm. 

OK, Qt Designer cooperation with KDevelop working now.


Then, I tried to install upgrade to KDE 3.0.2 from SuSE site. But RPM say that 
qt-designer and qt-devel-tools cannot be commonly installed. I tried install 
it with --force. But after it, Qt designer not work. I tried remove 
qt-designer package. Designer still not work. If I run it from terminal, I get message that designer caused segmentation fault in libcppeditor.so.

I have this same problem on KDE 3.0.3

Lumir Vanek

(Submitted via bugs.kde.org)
(Called from KBugReport dialog)

More information about the KDevelop-devel mailing list