Bug#46721: SuSE 8, KDevelop & Qt Designer - packages mess

lvanek at eanet.cz lvanek at eanet.cz
Wed Aug 21 09:34:02 UTC 2002

Package: kdevelop
Version: 2.1.3 (using KDE 3.0.3 )
Severity: normal
Installed from:    SuSE
Compiler:          gcc version 2.95.3 20010315 (SuSE)
OS:                Linux (i686) release 2.4.18-4GB
OS/Compiler notes: 

SuSE 8, fresh installation.

I tried to create dialog in KDevelop 2.1 with standart way - I created dlgname.ui file using File -> New....

1) I got question about loading ASCII file. I pressed NO
2) Dialog with question about program to open UI files. I typed "designer"
3) KDevelop started yast and yast installed qt-designer package. If I cancel this step, KDevelop doesn't start Qt Designer.  

But WHY KDevelop needs qt-designer package ??? qt-designer.rpm package contain old Qt2 designer and it is in conflict with  qt-devel-tools.rpm. 

OK, Qt Designer cooperation with KDevelop working now.


Then, I tried to install upgrade to KDE 3.0.2 from SuSE site. But RPM say that 
qt-designer and qt-devel-tools cannot be commonly installed. I tried install 
it with --force. But after it, Qt designer not work. I tried remove 
qt-designer package. Designer still not work. If I run it from terminal, I get message that designer caused segmentation fault in libcppeditor.so.

I have this same problem on KDE 3.0.3

Lumir Vanek

(Submitted via bugs.kde.org)
(Called from KBugReport dialog)

(Complete bug history is available at http://bugs.kde.org/db/46/46721.html)

More information about the KDevelop-devel mailing list