Bug#32677: problem generating QT template project

christoph.tapler at gmx.net christoph.tapler at gmx.net
Wed Sep 19 17:30:17 UTC 2001

Package: kdevelop
Version: 2.0.1 (using KDE 2.2.1 )
Severity: normal
Installed from:    SuSE
Compiler:          gcc version 2.95.3 20010315 (SuSE)
OS:                Linux (i686) release 2.4.7
OS/Compiler notes: 

When I try to generate a Qt template project, kdevelop complains about not finding a couple of files.
I have observed this behaviour and found out following:

The file processes.pl will be started to generate the template files. But this template assumes that the settings are in ~/.kde . That's for example _not_ true for me. In my case my settings can be found in ~/.kde2
And for that reason it's clear why kdevelop can't find the entries.* - files in this directory. I've tried to make a soft link from ~/.kde to ~/.kde2 and it worked.

A more technical description:
The first problem occures in line 14 of processes.pl: It geneartes a path which is not valid (respectively does have a different $KDEHOME as KDE has)

The problem arises in line 24 where kdevelop tries to open the (not existent) file

If you want further information, email me. 
Hint: If you need a better description and you are able to read german - my german is better ;-)

(Submitted via bugs.kde.org)
(Called from KBugReport dialog)

to unsubscribe from this list send an email to kdevelop-devel-request at kdevelop.org with the following body:
unsubscribe »your-email-address«

More information about the KDevelop-devel mailing list