[kdepim-users] Cannot select S/MIME signing certificate

Thomas Olsen tanghus at gmail.com
Fri Apr 16 10:17:52 BST 2010

On Friday 16 April 2010 11:04:42 Darknight wrote:
> 2010-04-16 10:55:22 Thomas Olsen
> > Just tried to sign a file from Kleopatra using said certificate which
> > failed because it is not trusted. Also I could see that it is not amongst
> > my Trusted Certificates in Kleopatra - could that be the reason for the
> > red X? I imported the certificate using "gpgsm --import
> > Thomas_Olsen.pkcs12". Should I have done something else?
> Is your cert released from a well known certification authority or is it a
> "private" certificate? In this case you need to import the CA certificate
> and trust it to have your cert listed as trusted/good.

Well it's the official certification authority issuing "Digital Signatures" in 
Denmark and it's listed "Other Certificates" together with Verisign; which BTW 
isn't in "Trusted Certificates" either.

Serial number: 3E48BDC4
Validity: from 11/2-2003 09:39 to 11/2-2037 10:09
Certificate type: 2.048-bit RSA
Certificate usage: Certifying other Certificates
Fingerprint: 8781C25A96BDC2FB4C65064FF9390B26048A0E01
> Be sure to check "Allow clients to mark keys as trusted" in your
> configuration, last time I tried this was needed.

Where would I set this? I cannot find it anywhere in Kleopatra. And the "Change 
owner trust" menu is grayed out.

Sorry for all the basic questions but I get very confused when trying to set 
up these things. If I get it working again I will definitely write down the 
steps and keep a backup. Last time I lost everything due to an HD crash :-(

Best Regards / Med venlig hilsen

Thomas Olsen
KDE PIM users mailing list
kdepim-users at kde.org

More information about the kdepim-users mailing list