KDE Plasma issue with tooltip position covered by mouse cursor

Duncan 1i5t5.duncan at cox.net
Sat Feb 17 03:10:21 GMT 2024

Lorenzo Sutton posted on Fri, 16 Feb 2024 18:33:47 +0100 as excerpted:

> I have an issue with tooltip position and (possibly) mouse cursor
> (size).
> My mouse cursor is set to Adwanita with a size of 48 and many
> application tooltips seem to 'ignore' or miscalculate the actual cursor
> size and place the tooltip right under the cursor - typically the 'tail'
> of the arrow pointer - I imagine the expected size is 24 (which I
> believe is the default size in most themes).
> The problem is that often tooltips hold valuable information which gets
> hidden in this way.

I've been noticing this for some time.  The bad news is that while I see 
you're still on 5, it continues in kde/plasma6 (live-git tho I last 
updated on the 8th, I'll probably update again tonight).  More on versions 

The good news is that while at one point it was *REALLY* bad -- the 
tooltips were appearing directly under the cursor "hot point", making it 
difficult to actually click -- that's not the case any more -- as your 
mashup image indicates, they're now under the cursor tail, not the hot-
point, so it's at least possible to click without playing dodge-the-
tooltip!  Tho the "under the hotpoint" bug may not have hit actual 
releases and/or may have been wayland-only (you say X; I'm wayland-only 
with the only X I have installed being xwayland).

And they've cut down on the "too many" tooltips problem, where they just 
say the same thing the button they're pointed at says or for common stuff 
like the windeco buttons, too.

> I can't find a pattern for this with UI toolkits apart from the fact
> that some specific GTK applicaitons like GIMP and Inkscape seem to
> correctly 'shift' tooltips out of the way of the mouse cursor
> (calculating better its actual size) as expected.

At a guess it's gtk3 apps that work.  At least, all my gtk3 apps seem to 
have the tooltips out of the way of the actual cursor, tho firefox seems 
to have them /just/ out of the way while claws has them /well/ out of the 
way.  Maybe gtk3 has adjustment builtin now, while claws is still adding 
its own distance calculation from before the buildin, so the tooltip ends 
up double-spaced away there.

Presumably gtk4 would have it too, but not gtk2 (it's likely they dealt 
with it for the wayland port even if it's the same on X, because window 
handling is so different on wayland a LOT of things needed redone where 
the X code likely hadn't been touched in years, and I don't believe gtk2 
was ported), if you still have any gtk2 apps around, and perhaps not 
individual apps that override the default handling.  Also, if you're 
running flatpack apps or the like, I'm not sure if the cursor size would 
be propagated through properly, and even if it is they're loading their 
own copies of libs from the flatpack (sort of like static linking as it's 
their own lib copy, but not, as it's dynamically loaded, just from the 
flatpack not the system), so it's possible they could be running older 
pre-fix versions.

> Theme and 'application style' are Breeze. Changing these (apart from
> resetting the cursor to whatever the theme includes), doesn't seem to
> mitigate the issue.

Confirmed.  Oxygen app-style here, a slightly patched (less padding around 
the title for a thinner titlebar) oxygen windeco, mellowgrey plasma style 
(kde4 vintage, IIRC) from kde-look, and a custom color scheme.  (Global 
theme says oxygen too but I don't believe I've ever touched that, setting 
individual elements as above instead.)

> Here is a screenshot mashup of different applications where I'm
> experiencing the issue:
> https://pasteboard.co/uwMmtlGjcCaF.png

FWIW, I was getting a no such image error at first, but turned out it was 
because I have uBlock Origin set to (high-security) default-reject off-
site connections and it needed gcdnb.pbrd.co allowed (from pasteboard.co, 
of course, presumably pbrd is them too, but it only needed the gcdnb 
subdomain thereof).  Then it worked. =:^)

Anyway, thanks for including the image link as it confirmed the exact 
behavior I'm seeing here.

> Any ideas or hints to any settings or theme hacks for this?
> This is with X and the following versions:
> KDE Plasma: 5.27.10 QT version: 5.15.12
> Running on Manjaro with the whole KDE desktop installed.

Gentoo here, wayland (as I said above, the only X installed is the 
xwayland shim to run X apps on wayland).  I run the kde/plasma desktop 
(exclusively but for CLI and weston as a backup compositor) but it's a 
"lite" version, no semantic-desktop integration (no akonadi or baloo), no 
policykit, no pipewire or pulseaudio (alsa-only)... and only plasma-
desktop plus selected apps and their deps (so missing a couple frameworks 
that aren't deps and without various apps including anything kdepim 
related due to the kdepimlibs akonadi dependency).

So the kde/plasma desktop, but slimmed down and without some of the family 
of apps some might include in  their definition of "whole kde desktop".

Which slims things down enough, along with smart-live-rebuild so I'm not 
rebuilding live packages that haven't actually updated, to run the live-
git versions of installed kde-frameworks/plasma/apps along with a few 
tightly kde-integrated non-framework deps (like plasma-wayland-protocols 
and phonon).  The live-git packages are from the gentoo/kde overlay.

As soon as gentoo/kde had kde6 builds available I switched to it where I 
could, tho like the kde upstream code, the gentoo/kde builds took some 
time to stabilize, so initially I had to manually handle some of the 
dependencies and not everything was available immediately so the plasma 
desktop itself remained 5.x for awhile, as did some apps.

But about 3-4 weeks ago I finally got rid of the last kde5 stuff except 
the qt5 compatibility stuff for vlc, etc, and by about two weeks ago I had 
found alternatives for all my qt5 stuff (the gtk-based celluloid replacing 
vlc being the last one, phonon is installed as a dep without a backend now 
making my "plasma-lite" installation even "liter"!), and had the qt5 
compatibility stuff turned off for kde as well, finally allowing me to 
uninstall qt5 itself.

As for what that kde/plasma6-live-git (again, last updated back on the 
8th) reports itself as, from kde system-setting about (qt is release 
version, the other two live-git reporting as...):

System Settings Version 6.0.80
KDE Frameworks Version 6.0.0
Qt 6.6.1
The wayland windowing system

As for ideas/hints...

You might try different cursor themes.

One set I downloaded recently (using the builtin download functionality in 
the kde cursor control panel) was "Empty Butterfly" in various colors.  
"Butterfly" in this case refers to the delta-wing shape of the primary 
pointer, while "Empty" refers to the fact that the interior is transparent 
-- the cursors are outlines in the chosen color, with the inside "empty" 
or transparent.  Included sizes are 32,48,64,96, but note that you may 
need to go a size larger than normal for visibility due to the empty 

This is what I'm using at present -- in the 96 size.  While the issue is 
still there, because the interior is transparent the effect isn't as bad 
-- while a letter of the tooltip might be obscured by the non-transparent 
outline, it's normally only one, and the word can be guessed/read based on 

A very similar "Empty" set is available too, with the more traditional 
arrow replacing the delta-wing/butterfly that I preferred.  You might 
prefer it since I see from the images that your current primary cursor is 
a traditional arrow.

A note on installation, however:  Apparently the author doesn't run Linux 
and just made their MS/Apple cursor theme available on Linux for those who 
want to use it.  As such, they apparently misunderstood the formerly X now 
XDG/freedesktop cursor specification, or maybe the command for the archive 
format they used, and the cursor files end up installed, IIRC, a subdir 
too deep.  So the cursor theme didn't actually show up in plasma's cursor 
control panel even tho it said it was installed.  But once I figured out 
what happened it was easy enough to find the files and move them up a 
subdir to match the arrangement working cursor themes used.  Then they 
worked. (Actually, while I was at it I manually moved them to the system 
dir, /usr/share/icons/, of course changing ownership and permissions 
appropriately. =:^)

FWIW I have a few other cursor themes installed too, but until this bug 
gets fixed the "empty" ones seem more practical.

Meanwhile, "bug" is exactly what this is.  But it hasn't irritated me 
enough to go looking to see if a bug is filed on it yet, filing one myself 
if not.  If you find or file such a bug, please post a link to it here, so 
I can CC as well. =:^)

Duncan - List replies preferred.   No HTML msgs.
"Every nonfree program has a lord, a master --
and if you use the program, he is your master."  Richard Stallman

More information about the kde mailing list