After working fine, audio is unavailable: "No output or input devices found"

Richard Troy rtroy at
Wed Sep 20 17:30:45 BST 2023

Hello everyone,

I'm new to the KDE community and have found it's both large and 
welcoming! And someone pointed me here as one of the places to ask about 
this problem. Here's my scenario:

Fedora Server 38, fresh installation, NO GNOME (!!), then an installation 
of KDE with a few utilities from other distributions. At this point I had 
rhythmbox working just fine.

The next morning, rhythmbox NOT running, so I don't know WHEN the problem 
occurred and therefore exactly what changed, but to finish things off, I 
needed to add some scanner software, didn't know much about the available 
packates so I installed a number of packages for testing, including two 
non-scanner-related packages:

    gimp   skanlite   sane   gscan2pdf   simple-scan   kdenlive

I also had mounted some NFS disks from the local net and needed to update 
the system's authorization files, so I moved in configurations for a 
number of other users and groups so that the file permissions information 
is all available on this box (I run a modest server farm). It's possible 
but unlikely I botched the auth-files somehow.

OH, and if it might matter: I've had SERIOUS problems with "Wayland", I 
can't even log in successfully with it - the session always crashes - yet 
KDE's cog-wheel type icon there during login somehow disappeared, thus 
taking the "Xorg" login option away, and so, not taking the time to do it 
better, I'm now logging in to "multi-user mode" (textually,) and then 
running xinit with a pointer to the KDE startup program. This works fine 
but it does change the ownership of some running processes from root to my 
user-id. AND, notably, I was running rhythmbox and playing music as I 
worked  after having done this, so I think it's unlikely it's related to 
this audio problem, but I don't really know that.

Later, when I decided to play something, I discovered that the speaker 
icon on the lower right has a red slash across it and when mouse-hovered 
over it says: "No output or input devices found"

Since then I've done a LOT of homework, including swapping out the whole 
operating system disk for one from one of the server systems, and thus 
proved the hardware is just fine.

Along the way I found that there was a conflicting version of piperwire, 

- package pipewire-pulseaudio-0.3.80-1.fc38.x86_64 from @System conflicts
   with pulseaudio provided by pulseaudio-16.1-4.fc38.x86_64 from fedora

So I fixed that.

Some software packages claim there's no audio hardware, but alsactl says 
there are either two or three "cards", depending on whether or not I've 
got a USB based plug-and-play controller plugged in. The other two are 
HDMI, and "Realtek ACL1220". There are SIX HDMI-capable monitors (all 
connected via "displayport" connectors - more on that in a moment), and 
while I've NEVER used them, these ASUS monitors MAY have built in speakers 
- I don't know. Meanwhile the Realtek is a garden-variety built-in affair 
that comes with the motherboard.

I've tried "dnf update", installed alsa-tools, alsa-ucm-utils, 
pulseaudio-utils and pulseaudio itself (which is when I found the conflict 
noted above), and tried using these as best I can as a Linux audio novice 
... and everything else I can think of...

OK, short of a fresh installation and NOT installing things I now know I 
won't need, ideas?

Now, about the HDMI stuff: The video card's manufacturer claims one can 
have independent audio streams per display - but again, I don't use them.

Thanks - oh, and if there's a better forum for this, please point me 


More information about the kde mailing list