How do I use kscreen?

Duncan 1i5t5.duncan at
Wed Nov 5 04:13:37 GMT 2014

Nikos Chantziaras posted on Tue, 04 Nov 2014 13:26:30 +0200 as excerpted:

> On 04/11/14 12:35, Duncan wrote:
>> Nikos Chantziaras posted on Tue, 04 Nov 2014 12:00:08 +0200 as
>> excerpted:
>>> [kcmshell4 kcm_kscreen] brings up an almost empty window:
>>> So kscreen works, but cannot offer configuration for my monitor, it
>>> seems?
>> [It's] working, but the interface [...]
>> 5) Clicking on any of the labeled rectangles in the top half, loads its
>> settings into the bottom (otherwise empty) half. (!!)
> Oookay. Hold the phone. There was zero indication that this is even
> clickable, lol.

Yes, like I said I /think/ the interface is supposed to be intuitive, but 
at least for long-time computer users used to more traditional interfaces 
it's anything but.

Originally I'd have had pretty much the exact reaction you did, except 
that I had a hint that it was a somewhat non-traditional interface and 
that it was not exactly initially clear how it worked, based on the 
various git comments, etc, I read about it.  Based on that I found myself 
asking how what I saw could possibly be interacted with, and basically 
tried stuff until I got some satisfaction.  Luckily that approach paid 
off and clicking the "i" was #1, with clicking the rectangle #2 after #1 
did /something/, but looked pretty stupid if that was all that the thing 

> And yes, I only have one monitor. Never had more than one.

Admittedly mostly OT bragging, but WTH...

Heh, my two big screens are 42-inch full-HD TV monitors here, stacked one 
above the other taking up pretty much the entire wall at the foot of my 
bed.  That's my main work area, with the third monitor being a 21-inch 
remaining from my previous generation solution, also full-HD, added since 
I still had it and there was a third output on the graphics card.  
Logically it's stacked on top of the others since that makes a nice 
logical desktop rectangle, but physically there's no room for it there so 
it's located on the wall to the side.  It's my "system status dashboard", 
running a nearly full-screen superkaramba theme.

Typical (and FWIW current) usage on the pair of main workspace monitors 
is minitube running full-screen in the top (logically middle) 42-incher, 
audio routed to the 5.1 home audio system, with two half-maxed (maxed 
vertically, half-monitor horizontally) konsole/firefox/message windows in 
the bottom one.

It's about 18 months old now, but here's a full-size (1920x3240 px) 
screenshot for an idea:

> However, even after clicking it and having the controls pop into
> existence, they're broken :-D  The resolution slider cannot be moved
> freely. It gets stuck and the refresh rate drop-list changes on its own.
> For example, if I move it to the left, the slider locks into 1024x768
> and cannot be moved anywhere else, while the refresh rate drop-list goes
> through various values instead when I attempt to move the resolution
> slider...

Well, due to frequency limitations, resolution and refresh-rate are 
inexorably linked.  Back in the CRT day I used to run monitors at as high 
a resolution as I could possibly get, often playing with the xorg 
modelines to push the monitor just that bit further beyond specified 
tolerance which still keeping vertical refresh high enough I could still 
tolerate the flicker (about 60 Hz for me on most CRTs, I found) .  FWIW 
that likely has something to do with my light text on dark backgrounds 
preference, since dark backgrounds don't blink as intolerably at 
borderline refresh frequencies as bright backgrounds do.  Of course 
modern solid-state digital displays have a much stronger notion of native 
resolution than CRTs did, full-HD resolution or slightly better (1200 
vertical instead of 1080) is generally considered "good enough", and that 
sort of modeline tuning to get that last bit of resolution out of the CRT 
is now a dying art.  Oh, well, can't say I miss it...

Anyway, it would appear that either your monitor or the nVidia 
proprietary drivers aren't exporting appropriate dot-clock information 
via RandR, likely causing xorg, randr and kscreen to default to rather 
conservative default values, severely limiting the available resolutions 
to those fitting within the resulting constraints.  If the nVidia 
proprietary driver configuration tools are giving you normal options, 
that would tend to implicate the nVidia proprietary drivers.

But I recall a time when the nVidia drivers didn't support RandR at all, 
so the fact that it's working at least to some extent is I guess better 
than it was.  Tho it's not like they have much choice, as pretty much 
everything is switching to live RandR-based configuration these days and 
a driver without at least minimal RandR support may well not work at all 
on a modern xorg.

Anyway, at least you have an idea how it works now, and perhaps you'll 
have the luck with kscreen that I never had with krandr and it'll 
actually work correctly at some point.

Meanwhile, now that you've satisfied your kscreen curiosity and since it 
isn't working anyway, as I said earlier you can set USE=-kscreen and 
remerge kde-base/systemsettings, and you should have the more traditional 
krandr interface back.  You can then unmerge kscreen or put it in @world 
and keep it, as desired.

Duncan - List replies preferred.   No HTML msgs.
"Every nonfree program has a lord, a master --
and if you use the program, he is your master."  Richard Stallman

This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list