keyboard and mouse not working after upadte to latest xorg server

Duncan 1i5t5.duncan at
Sat Aug 2 07:47:22 BST 2014

Peter Nikolic posted on Fri, 01 Aug 2014 23:05:58 +0100 as excerpted:

> Iam running Arch Linux on my main PC fully updated including the latest
> xorg server  stuff  , If i run startx i can use the terminal windows
> start programes  as root    .
> If i run kdm to use kde i get the login screen /greeter but have no
> mouse or keyboard .
> I have so far tried every thing i can find to attempt to solve this
> without sucess .
> Could use a little help and or suggestions as to where to look next

FWIW, here I use startx to start kde directly from a text login, no *dm 
installed at all, nor have I used a *dm graphical login since before I 
switched to gentoo in 2004, so there's a definite limit to my knowledge 
in that area.  In fact, I quit using *dm logins back on Mandrake in 
probably 2002 or so, precisely because the one I was using broke, while a 
text login and simply running startx from there "just worked".  My 
impression then and now is thus that a *dm login requires that more 
software machinery be configured and in working order, and that it's 
consequently more delicate and prone to breakage than the relatively more 
robust simple text login and startx as a normal user, with an xsession 
set as appropriate (to kde in this context).

Anyway, some questions/observations can be made:

You tried kdm, and you tried startx as root, but there's no indication 
you tried startx as a normal user (which is the way I launch X, with kde 
set as the xsession, here).  What happens if you do that?

That kdm isn't giving you mouse/keyboard in X while logging in as root 
and running startx gives you working mouse/keyboard points at a 
permissions issue, possibly related to systemd's logind configuration -- 
nobody logged in so it's not setting permissions appropriately to allow X-
based input activation, to /get/ that login.  While what little *dm stuff 
I know is long outdated (long /long/ before systemd's logind, for 
instance, which certainly changed the rules in that area quite a bit), 
checking whether a text login as a normal user and startx from there 
gives you working input, would test another variant on the problem, 
giving people more information to troubleshoot with.

You can also try a text login, and then switch back to kdm and see if it 
is suddenly working.  If that works, it's definitely dynamic-permissions 
related based on login.

Meanwhile, if you'd like startx to run kde instead of a generic session 
(as I do here on gentoo, but with a slightly different technique than 
suggested in the link below), since you're on arch, I'll refer you to the 
arch wiki:

With that you may find, as I did, that ultimately you don't need a *dm 
graphical login any longer.  Simply do a normal text login, and if you 
want to startx, just run startx as you would a normal command.  If not, 
don't. =:^)

...  Tho even if you don't use kdm for graphical login, if you need a 
screen-locker you'll still need to keep it installed as it provides the 
greeter for kde's screenlocker, without which you won't get a login 
prompt after locking the screen, and you'll have to kill X (using magic-
srq K or from a different VT) and run startx again if you activate the 
screenlocker.  FWIW, I don't need that screenlocker functionality as I'm 
the only user on my home computer and I deliberately keep private info 
off my netbook, so I just disable the screenlocker and use startx to 
start kde, and don't need to have kdm installed at all.

Duncan - List replies preferred.   No HTML msgs.
"Every nonfree program has a lord, a master --
and if you use the program, he is your master."  Richard Stallman

This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list