Kwin shortcuts not working

Dotan Cohen dotancohen at
Tue Mar 12 09:28:59 GMT 2013

On Sun, Mar 10, 2013 at 6:11 PM, Duncan <1i5t5.duncan at> wrote:
> In general, it's worth noting that kde has several keyboard shortcut
> configuring and consuming components.  kwin, being a window manager,
> should see all keyboard activity before it gets passed to anything else
> (if kwin doesn't consume it), so should consume its own shortcuts.  After
> that, AFAIK the general global hotkeys component (which with kde3 was a
> running khotkeys which I don't see with kde4, so I'm not sure which
> running process actually handles it now) is next in the queue, followed
> by passing anything remaining down to the individual apps, which will
> grab their local hotkeys, then process whatever remains as they normally
> would, dumping it into whatever widget has focus, usually.
> So the fact that plasma's hotkeys still work even after kwin's hotkeys
> quit working shouldn't be surprising, since they're processed by
> different kde components.  Since I don't tend to use plasma global hotkeys
> much, I'm not sure whether the clock hotkey is global (will still trigger
> if another app has the focus) or local (will only trigger if plasma has
> focus) or not, but either way, it's almost certainly a different
> component processing that trigger than kwin, which being the window
> manager, gets first pick of the keystream before anything else even sees
> it.
> Meanwhile...
> Kubuntu 12.10 doesn't tell me (as a gentooer, not a kubuntuer) what kde
> version you're running, but the date-based-version strongly suggests that
> it's older than the current 4.10.1 I'm now running, or even 4.10.0 (which
> was out in 13.02 using the same date-scheme).
> However, I did note a bit of weirdness in keyboard shortcuts in 4.10.x
> (4.10.0 I think, having run the betas and rcs if it's not a current
> problem they blur together a bit).  Whether it's fixed in 4.10.1 I can't
> say, as I was able to fix it locally by then.  Maybe you're seeing
> something similar, with an earlier version?
> In my case, the issue was associated with a kwin (aka desktop) effect
> which I had temporarily deactivated when I had a temporary issue with
> OpenGL.  When that was fixed and I tried to turn the effect back on, the
> hotkeys were messed up, and trying to reassign them in the effect
> properties from the middle tab of desktop effects didn't work.
> What I found DID work was reassigning them via the global hotkeys applet,
> kwin component.  This can be found in kde settings (aka system settings,
> except this is kde settings applying only to kde and to this user, NOT a
> system setting applying globally to the entire system, all users, inside
> and outside kde), common appearance and behavior, shortcuts and gestures,
> global keyboard shortcuts.  Select kwin as the kde component from the
> dropdown.
> Resetting the kwin hotkey I needed to reset there worked, while
> attempting to do it thru desktop effects did NOT work, for me.
> (FWIW, the effect in question here was the zoom effect, zooming in/out/
> normal size, vs moving left/right/up/down while zoomed.  I use the meta-
> arrow keys for both, with control as well for zooming, without it for
> moving while zoomed, and those hotkeys quit working.  But all my other
> hotkeys including all other kwin and kwin effect hotkeys seemed to work
> fine.  I don't know why it was just the zoom keys affected, but resetting
> it in global keyboard shortcuts worked, while attempting to set it in the
> zoom effect config dialog didn't work at all.)
> If you're lucky, the same thing will work for you.  Try resetting the
> hotkey using global keyboard shortcuts instead of wherever else you might
> have been trying to set it (you didn't say, except that it was in kde
> settings), and hopefully it'll work.
> One other thing to note.  Normally, kded should pick up config changes
> and apply them across kde immediately.  However, one other thing I
> noticed recently (with plasma in my case), was that a config change I
> made didn't take effect immediately -- only after I restarted kde.  I'm
> not sure if kded had aborted and therefore was no longer running in
> ordered to pass on the config changes, or if it was another problem, and
> it only happened the once so I had no chance for further troubleshooting,
> but if you're changing settings and they don't appear to take, do try
> restarting kde (either logout and back in if you're running a *dm GUI
> login, or quit kde/X and restart with startx or whatever, if starting it
> from a CLI login).  While that's normally not needed, sometimes kded
> apparently gets stuck and a full kde restart is needed in ordered to
> apply changes.

Thank you Duncan. In fact, I did try to set the settings again in the
inappropriately-named System Settings, and the computer has been reset
since then. The problem persists.

In any case, thank you for letting me know how the shortcuts are
consumed, that will definitely help me troubleshoot the issue. I'll
also check which daemons are running on my home system (where the
shortcuts do work) that may not be running on my work system (where
they do not).

Have a great week!

Dotan Cohen
This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list