KDM not starting after upgrade

Bogus Zaba bogsub at bogzab.plus.com
Sat May 21 19:35:51 BST 2011

On 05/21/2011 02:14 PM, Duncan wrote:
> It looks like so.  You'd have only encountered problems when you tried the
> kwin --replace and/or plasma-desktop steps, since they use opengl, and
> likely only kwin, as plasma-desktop uses opengl, but not to the same
> degree.  (FWIW, the comic-strip-plasmoid, of /all/ things, appears to use
> opengl accelerated drawing functionality that triggered an agp-only radeon
> drm kernel regression bug I had at one point.  The rest of my plasma config
> worked fine, as long as I didn't have a comic strip configured!)
> Thanks for the update!  Knowing how it was ultimately resolved... is both
> potentially helpful if others have the problem, and fills my own curiosity.
I did "try and run plasma and kwin from xfce" thing and plasma worked, 
but kwin caused a lock-up. As I was running from the command line I saw 
the messages from kwin and basically there were just four lines which 
more or less said :

1. The GL vendor is NVIDIA Corporation
2. The GL renderer is <my graphics card identifier>
3. The GL version is 2.1.2 NVIDIA 270.41.06
4. The driver is nvidia version 270.41.06

After that : total lock-up.

At that point I realised that in running nvidia driver version 270..., I 
had leap-frogged Slackware's (unofficially) packaged nvidia driver which 
was 260.... I uninstalled the 270 version, installed the Slackware 
package and found that everything worked just fine from the outset, 
apart from the need to put back some desktop backgrounds and a 
quicklaunch widget.

The moral is : don't try and be smarter than the guys building your distro.

Thanks again for you interest Duncan.
This message is from the kde mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

More information about the kde mailing list