A week of KDE4 usage

Alex Schuster wonko at wonkology.org
Tue May 10 00:49:49 BST 2011

Hi there!

[Oh, this has become rather lengthy. It's a description of my various
problems with KDE4, the details are not so important, no need to read it
all. My question is: Are your experiences similar to mine?]

I'm somewhat diesappointed with KDE4. I'm using it since 4.2, and it's
become much much better - but still, there are just so many bugs. Is it
just me, or it this normal? Would you suggest other people (being
unskilled uses, not hackers) to use KDE4? What OS and desktop
environment does your Mom's PC run?

One week ago, a friend wrote me an e-mail that he gives up on using
KDE4. He spent half a day to configure some KDE menus, quick starters
and such stuff on his uncle's PC. Works, but it took him a while. Then
he spent some hours to figure out how to create a distribution list, and
did not succeed. And he wonders why such basic things do not work - were
they not tested, did someone of the developers actuall try it out? Were
they working, and is this a new bug? Meanwhile, systemsettings had
crashed about 20 times on that day.
He compares KDE4 with a new car that has a great new injector
technology, but even in the fourth revision the windscreen wipers just
do not work. So he gave up. And he is sad, because his uncle, who does
not know much about Linux, got the impression is that this linux is
something for weirdos only.
I never used a distribution list with kontact, so I tried this for
myself. I created a new contact group 'Testgroup' in kaddressbook and
added some people with their e-mail addresses. Kmail then knows about
this Testgroup (it auto-completes it) - great, I think before KDE 4.6
addressbook and kmail did not exchange their data, Kmail did not know
about the people in the address book. But when I send a test mail,
nothing happens. It turned out that the mail is being sent to
Testgroup at myhost.my.domain, and not to the members. This seems to be a
known bug that was already fixed, but it's happening again. [1]

Now here's a list of other weird stuff happening during the last week:

Monday, my boss phoned me and wanted me to download a PowerPoint file
from our FTP server. This happens often, so I have a folder view with
some starters to access various sites via FTP, VNC and such. But when I
double-clicked on the current version of the .ppt document, dolphin
crashed. Seems to happen all the time I click a .ppt document. And when
one dolphin crashes, _all_ instances crash. It's annoying to re-create
them as I like them to be - for example, there is a dolphin grouped with
a konsole window, the dolphin has two tabs, each tab is a split view,
and they show specific locations. Takes a while to re-create this setup.
I can also just log out and in again, but then I have to save my work
first. And I lose stuff like all the tabs in akregator. Those seem to be
saved when I manually save the session, but this often messes up the
session, so I never do this without doing a backup of my .kde4 directory.
Back to the download. I clicked my program starter in order to open a
dolphin with the FTP target directory, but nothing happened. No idea
why, just another weird problem. I started dolphin manually and entered
the URL, but it did not connect. So I went to the text terminal and used
command line ftp. The problem is that I did not know the password,
that's what I have the wallet for. But how to access the wallet? I only
found out about the --show option to kwalletmanager after this, before I
used to open it by using the system tray. But I had the tray disabled
because of another nasty bug that made plasma crash dozends of times per
day [2]. So I had to first add the system tray plasmoid, then I could
get the password and downlaod the file. BTW, I wouldn't have been able
to download it with dolphin anyway [3], because it has German umlauts in
the file name.

The next problem was that akregator fired up two notifications every few
minutes, that the certificate of my own web server is unverified. Yes,
it's self-generated, and in the past I could just hit the accept button
and tell it to also accept it in the future. This no longer worked, when
I just came back to my PC I have to close dozends of these windows. The
problem somehow went away when I finally logged out, but that took a
while as I was busy doing things.

Same day: Akregator suddenly messed up articles - feeds showed entries
that came from other feeds. I restored the akregator configs and data
from a backup and this is working again. But many inexperienced users
would not have a clue what to do in such a case.
BTW, the date column in akregator is gone, this happens from time to
time here for two months [4]. It's not very annoying, unless I
accidentally click on the title column and everything is no longer
sorted by date, and I canot revert to sorting. Again, I restore the
akregator config file and alls fine again. For a while.

Another day I wanted to reboot, so I initiated a shutdown via the menu.
The screen went grey as usual, but the shutdown did not happen.
Applications and kwin were still responsive, and after a while I found a
confirmation dialog of the NEdit editor in the task list that I had to
close. No big deal, many users would have gone for the reset button.
There are some more applications that prevent a clean shutdown, they
crash when exiting and I have to close the crash handler dialog. Happens
every time with kmymoney, and sometimes with dolphin or kontact. But at
least I see the crash handler window, and the desktop is not shown
greyed out.

Yesterday, X crashed. No idea why.

Today, kwin crashed. No error message, no crash handler, just all window
decorations gone, no ability to switch virtual desktops. But maybe
that's because I just updated to 4.6.3 and did not log out and in yet.

Frequently, single windows also lose their window decoration. Did not
happen often yet. I think when turning off compositing the title bar was
back, but when I just experienced that problem again, this did not help.

That's the list of unsusal things that happened last week. Here's some
other problems that happen frequently:

- Some kde4init process dies a short while after login and presents a
crash handler [5]. And frequently, kded4 and knotify4 processes run at
100% until I kill them.

- The tray icon for tvbrowser sometimes gets gray, and no longer reacts.
I have to kill java and restart tvbrowser then.

- Dolphin sometimes does not update the amount of free space shown. It
also used to update the size of the files it shows, but at least
sometimes it does not do this now, I have to refresh (F5) to see it. And
yesterday something even weirder happened, it did not update a file that
I just had renamed, ls and dolphin showed a different name. Actually
that's quite bad for a file manager.

- Some application windows (e.g. dolphin) sometimes open maximized or
behind other windows. Some XView popup windows always open minimized. I
checked the window settings where I can define such ations (BTW, this
feature is great and I use it often), but none are set.

- Automatic spell checking stopped working in 4.4.4, and still does not 
work. I once started with a fesh .kde4 directory, and the problem persisted. 
I already had forgotten that this feature existed.

- Sometimes the plasmoids appear on the wrong desktops. I restore a
backup of plasma-desktop-appletsrc to fix this. Also when manually
saving the session, sometimes it gets corrupted, so I always back up
.kde4 before doing so.

- When logging in, Kontact warns that it is already running. When I
ignore this, it crashes. Old bug, will be fixed in next major kdepim [6].

- Konqueror has trouble with flash, some youtube links just show as
black area.

- When downloading a .zip file, konqueror offers to open it with ark.
Works, but after extraction ark opens my $HOME directory, not the
destination directory. This has always been so. Dolphin can manage .zip
files and treats them as folders, but this does not work when used as a
replacement for ark. I get an empty folder only. When I use konqeror to
navigate through local directories and click a .zip file, konqueror
tries to open the file itself (the url changes to
zip:/home/wonko/tmp/foo.zip/), but this is empty, too.

- When managing multimedia files with dolphin (or multiple instances of
dolphin), the system load goes really high because kio_thumbnail indexes
my video folders. Isn't this stuff cached somewhere? I killall
kio_thumbnail so I can work with dolphin, otherwise stuff like drag &
drop becomes very sluggish.
Talking about drag & drop: when I do this too quick, it results in an
effect like when the mouse button was still pressed. When I move the
mouse outside the dolphin window, it starts scrolling, and all files get

- When I drag the URL favicon from the konqueror address bar to the
desktop, why can't I edit the name of the starter this creates?

- When playing with activities, various strange things happen. And their
number tends to grow when logging in. For 4-5 times it occured that I
had the wrong activities / plasmoids on my desktops. I edited
plasma-desktop-appletrc and was able to correct this, and nowadays I
just restore a backp of that file.
I know this is work in progress, but there is no warning for the user
that trying this new stuff out might mess up things.

- My knotes no longer have the menu entry to send them to other (or all)
desktops. Well, the menu entry is still there, but greyed out. My
shortcuts still work though.

- Sometimes when such a problem appears, I start filing a bug, and while
reproducing it, another bug happens that I also could investigate
report, then konqueror crashes, then something else happens... and I
only report the first bug, because I have other things to do.

- About a third of the plasmoids I install by downloading don't work.
Probably not KDE's fault, but then some message like 'These plasmoids
are untested and not officially supported yet, so be warned that some of
them may not work properly' would be nice.

- I have a couple of folder view plasmoids. Sometimes when I log in,
some of them only show some error message. I open their settings, change
the path and apply, then it's okay. Then I change it back to the
original directory. This works, but it's one more of these annoying
little things that I have to do every time when I log in.

- Depending on my drivers (radeon with and without KMS, or fglrx) and
Xorg versions, I experience more or less graphics distortions. At the
moment, I see artefacts and random content of other windows for a short
time when widgets or menus open, before their own content is drawn.
Mostly a cosmetical problem, unless someone joins you at your PC and
suddenly bitmaps of the porn sites you just visited appear.
Some web sites in akregator miss text content when scrolling, after a
refresh or when marking the text it appears. This was far far worse with
an older Xorg and without KMS, so I turned compositing off which
improved the display. The fglrx driver never showed these problems, but
that has some strange memory problem with KDE 4 (I installed KDE 3.5 to
test this, there I had no swapping) so I want to avoid it. Probably more
an Xorg problem, but all this did not show up with other desktop
environments or window managers. Admittedly, I did not use them much, so
I might just not have noticed other strange effects happening there.

- Similar, but probably no Xorg problem: When you press a key while the
screensaver runs and the desktop is locked, you get a black screen and a
password dialog. But sometimes the current desktop appears for a flash
of a second. And when the system is busy, for a little longer, one time
it was more than a second. I don't care much, but normally noone else
has access to my PC. In an office, people probably expect that they can
leave their porn sites open when they lock the desktop and leave the PC.

- Starting OpenGL stuff like Quake3 or other fullscreen games sometimes
results in the resolution still being lower after exit. I can switch
back with xrandr, but sometimes the position of my applications is
already messed up. Or the panel becomes black, until I move the cursor
onto it, which restores most parts. So I used to start another window
manager on :1 and run the game in there, but this does not work with
every driver, sometimes only the first display has full OpenGL
capabilities. I don't know how it's now, because OpenGL is always slow
at the moment.
You know, this is the sort of trouble that you don't want to show
Windows users because it confirms their prejudice that so many simple
things just don't work right in Linux. But aren't they right?

I guess even more problems will come to my mind just when I sent this,
but it's enough I think. Please, don't take this rant as an offense. I
_still_ like KDE4 very much, and I think you guys do a great job. It's
free after all, and most of you probably do not get much for your work.
But I cannot suggest anyone else to use KDE4, unless that person is some
sort of geek who doesn't mind things to not work after an update, or
restoring ~/.kde4 backups all the time to make things work again. My
mother's new notebook will probably have Gnome 2 - it's ugly, but it
works. I'm tempted to try out Gnome3 for her, but that's very new -
although I were surprised if it took two years to become somewhat stable.


[1] https://bugs.kde.org/show_bug.cgi?id=228446
[2] https://bugs.kde.org/show_bug.cgi?id=258706
[3] https://bugs.kde.org/show_bug.cgi?id=206761
[4] https://bugs.kde.org/show_bug.cgi?id=268177
[5] https://bugs.kde.org/show_bug.cgi?id=271254
[6] https://bugs.kde.org/show_bug.cgi?id=185544
This message is from the kde mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

More information about the kde mailing list