Building DBusMenu-Qt

Duncan 1i5t5.duncan at
Fri Jun 17 23:57:32 BST 2011

David Doria posted on Fri, 17 Jun 2011 17:25:04 -0400 as excerpted:

> Following the instructions here:
> I cloned DBusMenu-Qt . Then I ran cmake, it says:
> "Please set them or make sure they are set and tested correctly in the
> CMake files:
> However, it lets me generate anyway. Then when I run 'make', I get:
> [  3%] Generating dbusmenuadaptor.cpp, dbusmenuadaptor.h /bin/sh:
> I searched for find . -iname *xml2cpp*
> in my /home/ddoria/bin/qt4, but it didn't find anything.
> Am I missing something in this process?

I believe the executable you are looking for is qdbusxml2cpp, which is 
part of the package (on gentoo) qt-dbus, which in turn is a part of qt, 
split-packaged on gentoo as qt-core, qt-dbus, qt-declarative... and a 
bunch of others.

So you either need qt installed, or a newer version installed, or to tell 
cmake where to find it, I don't know which.

FWIW, I have qt-4.7.3 installed here.  All available libdbusmenu-qt 
versions (0.8.2, 0.6.2, and a live-build version I didn't mention 
earlier, live-builds are fake-versioned on gentoo as 9999 for those brave 
enough to unmask and try them) on gentoo require qt version 4.6.3 minimum.

Duncan - List replies preferred.   No HTML msgs.
"Every nonfree program has a lord, a master --
and if you use the program, he is your master."  Richard Stallman

This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list