Plasma hangs, could not log in

Alex Schuster wonko at
Wed Jul 20 23:14:13 BST 2011

Anne Wilson writes:

> On Wednesday, July 20, 2011 04:32:55 PM Alex Schuster wrote:
> > Anne Wilson writes:
> > > Recently I had a similar experience, in that the bootup sequence
> > > never finished.
> > 
> > Did you also get the black screen, and nothing else happened from then
> > on?
> No, in my case KDE started to load - I saw the icons begin to appear, but
> when it got to the K icon it just stuck there.

Um, the icons of the splash screen? The last one is the big K here. Yes, it 
was stuck there, unless I waited for some minutes, or did some mouse clicks. 
And then all I got was a black screen.

[removing ~/.kde]
> > I hate to do this. Sure, it would help, as I was able to log in with a
> > test user, but configuring things back as they were takes quite a
> > while. And I didn't know beforehand it would take so long. I hoped
> > I'd find the problem soon, remove the offending program or plasmoid,
> > and all would be fine. I had similar problems in the past, and could
> > solve them this way. Like the dreaded bug that made the password
> > dialog useless when it was set to display three stars per key
> > pressed.
> > Then I would report the bug, someone would fix it, and it would never
> > happen again. The problem was that it does not look like there's a
> > single plasmoid being responsible for this, which was unexpected.
> I talked with the Fedora packagers, and we went through such things as
> clearing out caches, but to no avail.  There comes a time when getting a
> serviceable desktop as quickly as possible is the imperative.  I would
> much prefer to have found the cause, but my friends at Fedora agreed that
> we had tried everything that stood a good chance of telling us something
> useful, so I made the decision to get back to work.

If I had needed my PC to do important things, I'd either logged into another 
window manager, or moved the .kde directory temporarily so I could work and 
investigate later. But I like to solve these problems soon, if not they tend 
to stack up :)

> > > > Ctrl-C in the Akregator main tab does not work. Akregator
> > > > makes Kontact crash about four times per day.
> > > 
> > > Check for updates.  I saw that a while back, but it doesn't happen
> > > now, so it's almost certainly version or distro-version specific.
> > 
> > The Ctrl-C thing?
> No, the constant crashes.  It drove me wild for a while, but it's OK now.

Interesting, it's become much worse here, 2-5 Kontact crashes per day due to 
Akregator. Not long ago, this did not happen on a daily basis. Maybe it's 
since I am using KDE 4.6.5? Or could it be because I mainly use the Webkit 
engine now?
The most annoying thing about this is that I lose the from: and the subject: 
headers in mails I am currently composing. Akregator restores the session 
fine. If it doesn't happen more often, I can live with this. It's annoying, 
but worse tings happen here.

> > > Many of those things have already been addressed.  Yes, any
> > > database that attempts to index everything is going to be big. 
> > > The KMail issue, though, I consider to be more serious.  I take
> > > it that you are using the experimental KMail2?
> > 
> > Right. I thought it was considered stable by the KDE folks? I'm
> > running the ~amd64 branch of packagers, that is, they are not well
> > tested on Gentoo Linux, but are considered stable by upstream. At
> > least that's how I understand it.
> No, it is considered stable enough for early adopters to do the final
> testing - and there have been many more problems than the devs had
> experienced themselves.  It has been suggested that deleting any existing
> Akonadi database might help in a lot of cases.  It seems that people have
> tried the pre- releases and may well have some incompatibilities hanging
> around from those earlier releases, but I assume that this is not the
> case for you.

This may be the case, I once had the new KDEPIM stuff running for a day, I 
think it was being unmasked accidentally. But meanwhile I deleted and re-
created all Akonadi resources.
After dealing with this for a while now, I'm getting used to it. And I know 
what to do in case of problems. This morning, for example, KMail did not 
show any mails, and I had to restart both Akonadi and KMail until it worked 

> > > I understand that IMAP and DIMAP have been merged,
> > > and I assume that that means DIMAP (downloaded) in every case. 
> > > I'm not too happy about that myself.
> > 
> > Well, at least it gives me a backup in case my IMAP provider's server
> > dies, or when I'm offline. I was just surprised about the amount of
> > data, when my backup partition ran full due to some extra gigabytes
> > that were needed. And the backup runs much longer now. But it's a
> > minor problem, I can well live with that.
> Yes, it would be nice to know these things before-hand - would save a lot
> of worrying and wondering.

Yeah, a little dialog window informing me, and it would have been fine. But 
what I got during the first start was some Akonadi migration message 
windows, some showing errors, that vanished after a little while before I 
made screenshots.

BTW: I had some trouble sending this mail, it was stuck in the outbox. I got 
all kinds of weird messages (SMTP server does not support PLAIN, no 
connection to KDE-wallet, and others). I restarted KMail, I restarted 
Akonadi, I logged out and in again... but only when Thunderbird showed 
similar symptoms, I checked if something was wrong with the IMAP server. And 
it was indeed, it had a load of 550. KDE was not to blame, but I'm so used 
to KMail probelms now, it did not come to my mind that the problem was 

This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list