KDEPIM 4.6 prob^Wimpressions

Alex Schuster wonko at wonkology.org
Thu Jul 14 15:36:06 BST 2011

Duncan writes:

> Alex Schuster posted on Wed, 13 Jul 2011 13:20:50 +0200 as excerpted:
> > Oh, these newsticker applets. The KDE4 one didn't do anything when I
> > tried (a long time ago), but I don't like them anyway, they tend to
> > distract me.
> I got used to it after awhile...
> But I had forgotten that kde4 even /had/ a knewsticker for awhile, then
> it simply went away at some update or another.

I still have the 'News' plasmoid. Just tried it again, it says 'Fetching the 
news feed failed'. I tried to add another feed that is working in Akregator, 
same result. So, two years after I tried it for the first time, it still 
does the same, nothing. What a surprise.
[hours later]
Oh, now there are news items. The error message is still on the top, but 
some news items have appeared, although not those I added manually. But this 
was just a test, I prefer Akregator anyway.
[next login, due to KDE problems of course]
Again, no entries.
Entries are back. But they are old. The interval is set to 30 minutes, but 
one feed shows news of yesterday only.

Even the scrollbar does not work correctly. When I press the up or down 
arrows, it scrolls right to the top or bottom. When I click on the bar 
itself, it scrolls to this position. Like what the middle button should do. 
Sometimes it keeps scrolling even if I do not press any mouse button. And so 
on. An example for a plasmoid that either should not have these bugs, or 
that should not exist at all, it only make trouble, and is of no use. There 
should at lest be a warning dialog that it is not ready for use yet and one 
should try it on his own risk.

> Anyway, I know it was a bit dated as it only did rss and not atom feeds,
> and there wasn't really a way to show anything but headlines (tho that
> could in theory be arranged, a multi-line panel with the headline and say
> the first 3-5 lines of story below), but I'd have certainly enjoyed an
> updated newsticker than could handle atom, even if it only did
> headlines...
> Or if akregator could close the browser pane and only show the feed tree
> and "headers pane", with clicking on a header loading the full article in
> the configured browser.

Did you file a feature request? I like it the way it is, although the 
browser engine is not that good, probably because it uses Konqueror. So I 
configured Akregator to use Firefox as external browser.
Firefox also has RSS capabilities, which I did not try, maybe this would 
work better. I like Konqueror more, its look&feel, but it has more problems 
than Firefox. I think that some day I will have to make the switch to 
Firefox like you already did.l

> Or if combined mode (which is sort of headers mode with a summary, too)
> had a selection indicator for the active entry, and a way to mark
> individual articles read and to multi-select ranges and mark them read if
> desired, much as one can headers in the header pane of kmail, for
> instance.
> But I miss the filters, too, especially as I try to make my feed-reading
> time more efficient.  There's a LOT of stories I'd filter if only I
> could, while keeping those feeds.

Okay, my setup is less optimized. I have about 40 feeds, only few of them 
update daily, and I just advance from article to article.

> So as I said, akregator just seems klunky and undeveloped.  It's lacking
> the basic features like pane management and filtering/scoring that any
> basic article reading app really needs, whether it be news, mail, or
> feeds.  (I'm not a major IRC/IM user so I don't know if it could fit in
> that class or not, but certainly the others do.)  The lack of these
> features only serve to accentuate how well they work where they're
> present.

Using feeds is relatively new to me, I didn't even know other readers have 
these features. Maybe that's why I don't miss them.

> (FWIW, kmail isn't perfect here either.  If I had my way, I'd have it's
> tri-pane layout arranged much like I do pan's, full width headers at the
> top so I can get all the usual columns and a reasonable width subject/
> title without horizontal scrolling, folder tree and body pane below, with
> the folder tree actually to the right instead of the left, as to a
> western left to right, top to bottom reader, the lower right is the low-
> focus corner, and I spend far less times changing folders or newsgroups
> than I do reading headers or their full messages, so the folder list
> works real well there.  But kmail's pane layout isn't as flexible as
> pan's and while it has a short folder list option, it places it beside
> the header pane which is the one that needs the extra width in the first
> place, so there's little point!  There's no option to place the short
> folder list beside the message body pane, which is where I really need
> it, even if it won't allow me to put the folder pane to the right, which
> I'd actually prefer, but I'd settle for it to the left if only it could
> be beside the body pane instead of the header pane!  Pan by contrast has
> a layout setup with three numbered panes in the various possible
> configurations, and a separate setting that lets one choose which pane,
> tree/header/body, corresponds to which number in the layout diagram, thus
> making any possible arrangement of the three panes actually configurable.)

Yes, clipping the top of the folder view and enlarging the message list 
would be nice. It would be cool if one just could drag the panels as one 
likes, like I do in Amarok.

> > [KDE4's Amarok]
> > I can under stand this. But I'm happy with it, because while being
> > entirely different, I like Amarok very very much.
> I'm glad /somebody/ likes it! =:^)

Very much indeed. It's still buggy though, don't expect it to always start 
playing music just because you pressed the play button. Or to have a usable 
progress indicator, that you can drag around. If often takes several seconds 
to start playing a song. From time to time it even crashes.

There really must be something about it why I _still_ like it so much.

> >> It worked here and I can see it in klipper. <shrug>  Either you have
> >> some other klipper related issue or some other akonadi issue, or
> >> perhaps I didn't follow your reference correctly and you were
> >> talking
> >> about something else entirely.  That's entirely possible as the
> >> reference wasn't entirely clear to me.
> > 
> > Sorry I wasn't clear about that. Klipper is working fine, but I cannot
> > access it by clicking its icon in the system tray.
> OK, makes MUCH more sense, now!  =:^)  I was very confused on that one
> for a bit.
> But I /think/ I used klipper on 4.6.5, and /know/ I've used it on 4.6.95,
> specifically by clicking the tray icon, without issues.  So while I can't
> quite confirm that it worked on 4.6.5, if it's still broken in the same
> way on 4.7 (assuming of course they don't break it between rc2 and
> release), it's gotta be something in your setup, as it is working here.

Yes, I also assumed it's a local error here. And somehow it's sorted out 

> One thing that might make a difference, tho.  I have my systray in a
> panel at the top-left corner.  If the bug is that it's opening the popups
> down and right, I'd not see it as that's expected here, but it'd be off-
> screen for systrays in the traditional bottom right corner.  Since you
> can have multiple systrays in kde4, why not add another systray plasmoid
> somewhere else, even on the desktop, and see?

Well, only Klipper and KNotes were affected, all other entries worked as 

> > When logging in, KDE did not come up. The splash screen stayed for
> > longer than normal, then the screen went black, and stayed like this.
> > Going black is normal, KDE takes about three minutes here until
> > everything is started (plasma-desktop is using all the CPU during this
> > time), but now it never finishes. I let it run for a couple of hours
> > this night, then I killed plasma-desktop, and finally the desktop came
> > up. I started plasma-desktop in a Konsole, but it still only eats CPU
> > time.
> > 
> > Time for testing with other users, old configs, bisecting... again.
> Try renaming your $KDEHOME/share/config/plasma-desktop-appletsrc file.
> That contains your entire plasma desktop layout (yes, in a very
> complicated for kde config files SINGLE file!), so you'll lose that
> unless you have a proper backup somewhere, but it's very likely to let
> you back into plasma-desktop again, then.  If that doesn't work, try the
> other plasma* files in the same dir.
> If you can't tell, I had problems with that one before, myself, tho they
> were a bit different than yours (mine were magically multiplying
> activities).

Yeah, we already discussed that recently :)  But copying the plasma* files 
from a backup did not help. So I copied back the whole .kde4/share/config 
directory, and I had my desktop back.

> > And about KMail... it does not show _any_ mail any more. In the folder
> > view, I see folders with unread messages, but those were still unread
> > when I logged out of KDE. It does not scan for new mails. An when I
> > select any folder, it does not show the contents, it just says it's
> > fetching the contents, and I should wait.
> That sounds like a problem I had right after the kmail2 conversion.  I'm
> not sure what caused it, but I know how I fixed it, tho it's a bit
> complicated to explain (not that I let that stop me!).  And there's still
> a quirk to it.
> The bottom line is that mail-fetching seems to work best if you configure
> not kmail, but akonadi, to remember the passwords, etc.  In your akonadi
> resources, however you configure them (akonaditray/akonadi-kcm,
> akonadiconsole, or thru kcontrol's akonadi resource config, tho that last
> one might be a kde 4.7 change since I'm running rc2), find the resource
> for each mail account and hit modify.  This should popup a dialog with
> the configuration, *AND* a kwallet prompt.
> Type in the kwallet password and setup your account info including the
> account password.  Saving it here lets akonadi control it instead of
> kmail.

I think that's how it is set up here, but I did not have to do this 
manually. The passwords are in the Akonadi resources already.

> When akonadi/kmail starts and does the initial fetch, for some reason
> I've not quite figured out but that might be related to the fact that I
> have pop3 accounts on two different servers, I have to actually type the
> kwallet password twice.
> But here's the trick.  After I type it the first time, it'll apparently
> check the first account(s), but then kmail will freeze, because it can't
> get to the second set, because I haven't typed in the kwallet password
> for it yet, because it hasn't prompted me for it, because apparently it
> can only raise one prompt at a time!!
> So every time I restart akonadi for whatever reason (be it just an akonadi
> stop and restart, or kde, or a full reboot), I have to type in the first
> kwallet password, then open kmail, look at the fetching mail thing at the
> bottom right (which will sit there forever, doing nothing, waiting on a
> kwallet dialog that I never got, if I don't attend to it), click the
> little arrow beside it to expand the jobs, click the button to the right
> of each to cancel it, wait a few seconds for it to actually cancel
> (during which I can be canceling the others)...
> Then when all of them are canceled and the back-and-forth indicator
> disappears, indicating idle, *THEN*...
> I can hit the kde fetch-mail again, and since it has the passwords for
> the first account(s), it'll get them, but popup the kwallet dialog for
> the other accounts, that were frozen in the fetching state before.
> NOW I can type in the kwallet password a second time, and the second set
> of accounts fetch.
> After that, akonadi/kmail remembers the passwords and can continue the
> periodic mail checks as it's configured to... until such time as I shut
> down akonadi again and restart it, thus triggering the whole double-
> kwallet password with the cancel-fetch in the middle sequence once again!
> On the bright side, akonadi seems stable enough that I normally only have
> to do this once per kde login.  It'd certainly drive me crazy, or more
> likely, very rapidly to some other client, if I had to go thru the
> sequence for each mail check.

At least something that is working here without trouble. Well, nearly, some 
days ago I had the problem that Akonadi asked the Wallet for the password, 
and I had to enter the Wallet password first. But after 1-2 seconds, KMail 
asked for the password on its own, which I did not want. But that has not 
happened again.

> <shaking head>  The stuff we put up with...

Yeah. A lot of trouble, sometimes I wonder if it's worth it.

I made some more progress. I wanted to delete my IMAP resource and the one 
for the local folders. Before this, I made a backup of all ~/.* stuff, but 
the Akonadi module (in the system tray) also has an option back up the 
Akonadi stuff. I tried that, but I get an error message that neither 
mysqldump nor bzip2 can be found. This worked fine two weeks ago, and both 
binaries are still on my system.
Whatever. I deleted both resources, but the local folders resource is being 
re-created instantaneously (with a path of ~/.local/share/local-mail). Then 
I added an IMAP resource. Nothing happened. I clicked again, and after a 
while, I had two new IMAP resources. I deleted one, and wanted to change the 
settings of the first one. Nothing happened. I waited for some minutes, then 
I tried to close the window. I was told the application lo longer reacts, so 
I killed it. Oh my. But the next time I did the same, it worked just fine.

In the settings there is an entry for the trash, that was empty before. In 
the new resource, it is already defined, the name is 'Mülleimer'. In KMail, 
however, it shows up as 'Müllemer', with a missing 'i'. Strange. It isn't 
being used anyway, my local folders also have one. Deleting via hotkey 
again does not work, I am being told that this hotkey is ambigous, but I do 
not see how.
Oh, and  just found another folder, 'Versendete Nachrchten', which should be 
'Versendete Nachrichten', meaning sent mails.

The 'Could not create collection' notification which I had every few minutes 
no longer happens, this is good. But sending mails did not work, they just 
stay in the outbox of my local folders.

Finally, it worked out. I think I had to go to the identity settings and 
select folders for sent mails, drafts and templates. I'm doing this often 
these days, after changing settings, those folders are set to arbitrary 
locations, which sometimes no longer exist. Now some of the mails I sent 
yesterday are _somewhere_ along my folders, which I have a lot of.

Still, my local mail folders were missing - the 'Local Folders' resource 
points to .local/share/local-mail/, and when I change this to 
.kde4/share/apps/kmail/mail, my folders there do not show up. So I created a 
'KMail-Maildir' resource, pointing to that directory. So, even if the 
locations of both the 'KMail-Maildir' and the 'Local Folders' point to the 
same directory, only the former displays my custom folders. Then I moved my 
custom folders with KMail into the 'Local Folders', and FINALLY, things are 
back as they were.

Nearly. Now I see 15 new mails in my sent-mail folder of my 'KDE-Folder' 
resource, that I swear were not there just minutes ago. And 180 mails are in 
its trash folder. All the folders of this resource were empty, except for 
special folders which I moved to the 'Local Folders' resource. I am very 
confident that those sent messages used to be in my main IMAP server's sent 
directory, where KMail stored them for years. WHAT IS GOING ONHERE!

That was yesterday. Today, I wanted to finish this mail, but Kontact was 
_very_ unresponsive. It did not use CPU time, but it took nearly a whole 
minute until the file menu opened, or until the windows contents were being 
redrawn. I quit Kontact, restarted, and it was fast again.
Then I configured the sent, drafts and templates folders for my three IMAP 
accounts, some still had arbitrary folders.

While writing this last paragraph, I opened the Akonadi settings in order to 
look up the exact name of the 'KMail-Maildir' resource I was to write about. 
I found two additional resources (akonadi_maildir_resource_12 and _13), no 
idea where those come from, clicked one, and Kontact crashed. At least my 
mail was not gone (only the subject, this happens every time KMail quits 
while there are open composing windows). 
These resources have no folder configured, it is empty, so I deleted them. 
But it's scary how stuff appears in it and  don't know why.

Speaking of 'scary': Akonadi is. Before, mail setup was relatively easy. But 
now, mail is not fetched from the IMAP server, but from strange resources 
that do weird things, multiply by themselves, use database concepts I do not 
know much about, and all that. It's an additional layer between that 
complicates things. I don't say this is a bad thing, I see there are 
benefits, but it's scary, and I had much trouble with it.

My list of current KMail problems:

- The folder list often shows folders with unread mails, but there are
  no unread mails. Changing into another folder and back sometimes helps,
  but not always. F5 does not help.
- Frequent notifications like: <server>: Saving failed, server replied:
  A008494 BAD Invalid system flag \RECENT
- Subject and From headers are empty in composing windows after KMail was
  quit and restarted
- Something is munching 'i' letters here :)

It seems can work with KMail again as before. Finally. This took quite some 

This message is from the kde mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

More information about the kde mailing list