KDEPIM 4.6 prob^Wimpressions

Alex Schuster wonko at wonkology.org
Thu Jul 7 01:33:56 BST 2011

A little update on the KDEPIM situation. Kontact sort of works now, but it 
feels slower than before. Even changing between Kontact's different modules 
is slower now. I think about not using Kontact at all, but its individual 
components, with their windows grouped together (a really cool feature of 
KDE4 which I often use). Well, it's not _really_ bad, switching takes 1-2 
seconds, but it used to be instantaneous before, and I like to quickly peek 
into Akregator and back to see if there are new messages.

Kontact's summary shows an over-due to-do item, but when I click on it, the 
to-do list is empty. Probably a migration problem, but why does it show up 
in the summary then? But I did not use this feature much, so I don't care 
about the lost entries.

Quite often an IMAP folder still shows unread mails when I already had read 
them all. Selecting another folder and again the one with the unread mails 
usually fixes this.

What I liked about the old KMail was that I could open folders in tabs. The 
problem with this was that folders opened in tabs did not get checked for 
new mail, I hoped this would be fixed. But it seems this feature is gone 

I wanted to see if distribution lists work with the new Kontact - they did 
not with the old one, a mail to TESTGROUP would not go to the email 
addresses of this group's members, but TESTGROUP at myserver.mydomain. But when 
I open the address book and enter a new group, the new KMail does not know 
about this group and will not autocomplete. Seems like KMail does not know 
about any of my contacts. 
I do not understand at all how this works. I still have the contacts in my 
address book, so the migration has worked for them, but when  I open the 
settings, they show the location as ~/.kde4/share/apps/kabc/stdvcf, and this 
directory is empty. So all this stuff is in Akonadi's mysql database now? 
What's the purpose of this empty directory?

When moving messages from my inbox to another folder, they often (but not 
always) still show up, but grayed out. I already know this behavior from 
some other mail clients I tried, except for the old KMail and Thunderbird, 
it can be fixed by logging into my IMAP server and running mutt. When 
quitting, I am asked whether to purge the deletes messages. I wonder what I 
could do if I had not shell access to the server.

Today I unsubscribed from the ubuntu-users list which I do not read anyway, 
and because of the 250M this folder takes on the IMAP server, I decided to 
delete it. I also wanted to verify if bug 239859 still happens, KMail used 
to crash when deleting IMAP folders while still having it open.

Well, what do you think happened? Right, Kontact took ages deleting this, 
became unresponsive, after half an hour I killed the process. 
akonadi_imap_re still was quite busy. When starting Kontact again, a 
composing window with an unfinished mail opened, but not the main window. So 
I killed Kontact again. I stopped the Akonadi server, restarted it, and now 
Kontact was working again.
Again, I tried to delete the huge mailing list folder, and this time I 
waited for about two hours. Kontact was still usable, but very slow, and the 
KMail part did not display mails. akonadi_imap_re used about 40% of CPU 
resources, having an accumulated total time of an hour now. This process 
uses a lot of CPU resources even when I do nothing with Kontact, same goes 
for mysql.

Finally, I got an error message, the folder could not be deleted. So I 
deleted it with Thunderbird, which did the job in seconds. KMail still 
showed the folder and its contents, but after a restart it is finally gone.

Sometimes I get notifications like this from my IMAP server:
<server>: Saving failed, server replied: A015537 BAD Invalid system flag 
\RECENT. This just happened when changing into a folder that has a new mail. 
This morning, I had some similar message, but it told me about some 
conflicting flags on the IMAP server, and asked whether to keep version A, 
version B or both. I was in a hurry so I did not notice what the problem was 
exactly. I think I kept both.

Now, when I select this folder again, I get this message, every time:

<server>: Remote id is empty or invalid.

And the folder has no entries. Restarting KMail and Akonadi does not help. 
At least I can still view it with Thunderbird.

Oh, and after this last restart, the folder view shows one unread mail in 
the drafts folder. When I select this folder, there is only one mail, grayed 
out, it's the former draft of this mail I am just composing now. There are 
other drafts, but they only show up in Thunderbird, not in KMail.

I logged out and in, and now my drafts are back. The other folder is still 
empty, but I do no longer get the 'Remote id is empty or invalid' when 
selecting it.

Wow, this became longer than I thought. Now I just read that KDEPIM 4.6.1 
has been released, let's see if this will improve things, I guess Gentoo 
will have it soon. If not, I will delete my account and re-create it, with 
IMAP and the mails not being local this should do no harm.

Maybe I should report some bugs on bugs.kde.org instead of writing here, but 
this would be a lot of reports. Maybe when I have more time than now. And 
then, I wonder if it is really only me seeing these problems. Shouldn't the 
KDEPIM devs see most of them already and hopefully do something about it?

This message is from the kde mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

More information about the kde mailing list