cannot use OpenGL composite anymore [SOLVED]

Momesso Andrea momesso.andrea at
Wed Mar 24 10:38:30 GMT 2010

On Tuesday 23 March 2010 21:05:55 Duncan wrote:
> Momesso Andrea posted on Tue, 23 Mar 2010 17:52:15 +0100 as excerpted:
> > Since a couple of days OpenGL composition method stopped working. When I
> > try to switch to it it displays this (pretty useless) message.
> > 
> > 	Failed to activate desktop effects using the given configuration
> > 	options. Settings will be reverted to their previous values.
> > 	
> > 	Check your X configuration. You may also consider changing advanced
> > 	options, especially changing the compositing type.
> > 
> > And it reverts back to Xrender, that works fine, but is really slow.
> > The xsession-errors says something, but I can't undertand it:
> [snip error]
> > I'm using gentoo ~amd64 10.0 no-multilib profile, kwin 4.4.1,
> > xorg-server 1.7.6 and I tried all the available versions of the intel
> > drivers, including 9999.
> > 
> > I cannot remember of any recent upgrades that might be related to the
> > problem, but. as this is ~arch there are upgrades everyday, while it
> > might take a week before I log out of my kde session. So I'm not sure of
> > what upgrades may have iterfered.
> > 
> > I tried with a brand new ~/.kde4, but that didn't help.
> > 
> > I'm running out of ideas, please help me :)
> Gentoo/~amd64 no-multilib user, eh?  Same here.  =:^)

Yeah, your posts on this ML and on gentoo-user ML are always a great source of 
information for me :)

> Heh, at least you got a bit of warning.  Here, my netbook simply started
> crashing every time I tried to start X/KDE.  My workstation, using AMD
> Opterons and a Radeon, with (as you) gentoo/~amd64 no-multilib, is fine.
> My (32-bit) ~x86 netbook using Intel for both video and CPU, not fine
> (well, it wasn't, it is now).
> Try downgrading mesa.  That's what it was, here.
> The version that failed: mesa-7.8_rc1 .
> The version that I had been running, that worked fine both before and
> after I downgraded back to it: mesa-7.7-r1 .

As tassilo pointed out rc2 works fine and is already on tree

> Due to the fact that it was my netbook that had the issue, and I build the
> netbook image in an ~x86 chroot on my (amd/radeon) workstation, then rsync
> it to my netbook to actually run, I was of the opinion that the problem
> was likely something unique to that (rather strange) setup; that it would
> have been fine had I built on the hardware and could detect things
> properly on its own.  I thought it might also be kernel related, as the
> kernel on the build machine is 2.6.34-r1+ (git kernel, just past rc1),
> while the kernel on the netbook is 2.6.32.  So I thought it was just me.
> But now you're saying you're having very similar issues (if it's the sameb
> mesa versions and downgrading it fixes 'em, it's almost certainly the
> same!), on a 64-bit Intel machine as I had on the 32-bit netbook.  So it
> would seem it's not my peculiar situation after all!
> BTW, I run FEATURES=buildpkg, so all I had to do was take a look at the
> binary package versions I had built, and downgrade back to the last one.
> I didn't have to do an actual mesa rebuild.  If you're not running the
> same, I'd suggest you look into it.  That can be a really handy feature,
> on occasion. =:^)

I just use buildsyspkg, since I often run out of space :P


This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list