cannot use OpenGL composite anymore

Momesso Andrea momesso.andrea at
Tue Mar 23 16:52:15 GMT 2010

Since a couple of days OpenGL composition method stopped working. When I try 
to switch to it it displays this (pretty useless) message.

	Failed to activate desktop effects using the given configuration options. 
	Settings will be reverted to their previous values.

	Check your X configuration. You may also consider changing advanced 		
	options, especially changing the compositing type.

And it reverts back to Xrender, that works fine, but is really slow.

The xsession-errors says something, but I can't undertand it:

kwin(30556) KWin::Extensions::init: Extensions: shape: 0x "11"  		
composite: 0x "4"  render: 0x "a"  fixes: 0x "40"
kwin(30556) KWin::Workspace::setupCompositing: OpenGL compositing
kwin(30556) KWin::SceneOpenGL::initBufferConfigs: Drawable visual (depth 24 ): 
0x "a3"
kwin(30556) KWin::SceneOpenGL::initBufferConfigs: Drawable visual (depth  32 
): 0x "5e"
kwin(30556) KWin::SceneOpenGL::initBuffer: Buffer visual (depth  24 ): 0x "a5"
kwin(30556) KWin::SceneOpenGL::initRenderingContext: Couldn't initialize 
rendering context ("error: GLXBadContextTag[168], request: <unknown>[152], 
resource: 0x1403cc2")
kwin(30556): Failed to initialize compositing, compositing disabled 
kwin(30556): Consult
kwin(30556) KWin::Client::readUserTimeMapTimestamp: User timestamp, initial: 
kwin(30556) KWin::Client::readUserTimeMapTimestamp: User timestamp, ASN: 
kwin(30556) KWin::Client::readUserTimeMapTimestamp: User timestamp, final: 
'ID: 56623396 ;WMCLASS: "systemsettings" : "systemsettings" ;Caption: "Sorry – 
System Settings" ' : 14854945
kwin(30556) KWin::Workspace::allowClientActivation: Activation: Belongs to 
active application
kwin(30556) KWin::Workspace::updateClientArea: screens:  1 desktops:  6
kwin(30556) KWin::Workspace::updateClientArea: Done.

I'm using gentoo ~amd64 10.0 no-multilib profile, kwin 4.4.1, xorg-server 
1.7.6 and I tried all the available versions of the intel drivers, including 

I cannot remember of any recent upgrades that might be related to the problem, 
but. as this is ~arch there are upgrades everyday, while it might take a week 
before I log out of my kde session. So I'm not sure of what upgrades may have 

I tried with a brand new ~/.kde4, but that didn't help.

I'm running out of ideas, please help me :)


This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list