Which Qt version required for KDE4.4?

Nikos Chantziaras realnc at arcor.de
Tue Feb 2 05:26:29 GMT 2010

On 02/02/2010 05:35 AM, Sagara Wijetunga wrote:
> Hi all
> The kdebase-runtime-4.3.98/phonon/kcm/devicepreference.cpp requires
> <phonon/globalconfig.h>  which is not available in Qt 4.6.0 installation
> and there is no such file in Qt 4.6.1 package either.
> So which version of the Qt required to compile KDE4.4 RC3?
> Btw, I have not compile and install the Qt 4.6.1 due to its long
> compilation time, does the Qt 4.6.1 generates a phonon/globalconfig.h at
> compile time?

I'm using Qt 4.6.1 without problems.

KDE 4.4 required at least Qt 4.6.0. 4.6.1 is recommended (it fixes at 
least one major bug with Plasma crashing on 4.6.0.)

As for you problem, I think you need to disable Qt's Phonon altogether 
when building it and use the KDE-version of Phonon 
(http://phonon.kde.org.)  It should be a drop-in replacement for Qt's 
Phonon but works with KDE. At least, that's how it seems to work here.

This message is from the kde mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

More information about the kde mailing list