plasma-desktop (KDE factory) acting up?

Alex Schuster wonko at
Wed Dec 1 00:50:32 GMT 2010

Duncan writes:

> Alex Schuster posted on Sat, 13 Nov 2010 23:57:41 +0100 as excerpted:
>> Duncan wrote:
>>> Alex Schuster posted on Sun, 31 Oct 2010 20:51:12 +0100 as excerpted:

>> Sound really cool. I like shell scripting very much, it's astounding
>> what things you can do by combining some little commands. A little
>> example is another logging plasmoid that shows the output of a little
>> script that outputs the state of my four drives every ten seconds.
> Drive state?  Temps?  I effectively do that using smarttemp, logging the 
> result.  I could do similar with smartmon, but monitoring some of the 
> health stats, but haven't bothered.  Tho if I did I'd certainly script a 
> conditional checking the drive temp and shutting down if they got too 
> high, as I lost a drive a few years ago when the A/C went out on a summer 
> day when it was > 113F/45C outside... let alone inside... let alone in the 
> computer I'd left operating, which was probably still circulating 55C+ air 
> around as the drive died at I'd guess at least 75C.

I have two SATA and 2 PATA drives, three of them should be spun down
most of the time. I like to see the current state on my desktop
because I want to see when something makes them spin up again. hdparm
-C does this. And while I was at it, I also wanted to get the temperature.
I don't know about smarttemp, did you mean hdtemp? That's what I use.
But there's a problem with this, the periodic calls of hddtemp make the
drive not spin down automatically after a while. So I monitor only the
system drive's temperature.

I'm not too concerned about the temperature, though - this is not
Phoenix here. Hey, we even had a little snow today. And there is the
survey Google did, showing that heat is not such a big problem as people
thought - temperatures up to 45C are okay, and the failure risk is
higher at temperatures below 35C.

>> I filed a bug and posted some updates while I changed my configuration:
>> Things were fine, but then it started happening again. I was finally
>> able to track this down - it was the file watcher plasmoid I just
>> mentioned some lines above. It logs a file that contains the output of a
>> script that adds four lines every ten seconds, containting the state of
>> my hard drives. It had reached a size of 45M, and this is too much for
>> the plasmoid... I wonder why.
> Well, one of plasma's problems is that it runs everything in the same 
> process.  Apparently, along with everything else, that was just too much 
> for it.

Yeah, having all in one process is a problem. If it weren't like this,
top would have shown me the malfunctioning plasmoid directly.

>> I found a workaround, the file is shorter now, and plasma takes much
>> less memory. Problem solved!
> Of course, using tail --follow, fed to a yasp-scripted script, avoids the 
> issue entirely, since you only get the configured number of lines of 
> output.

I still had no time to play with yasp-scripted, but for the moment I'm
fine with this workaround: Watch the log file myself with tail -f
--follow=name, and let the plasmoid watch this file. So now I have this
in .kde4/Autostart/:


for logFile in /var/log/*/current
        if [[ -r $logFile ]]
                tail -f --follow=name "$logFile" >> "$myFile" &

> FWIW, to keep control a bit tighter on access to /var/log/messages, when I 
> setup yasp-scripted to tail it, I setup a script that does a tail -100 on 
> it, to be run as root.  Then I configured sudo to allow my user to run 
> that script (passwordless) with no parameters, which should be a 
> /reasonable/ permission lockdown, I think/hope (at least given that I'm 
> specifically allowing the user to view the last 100 lines of /var/log/
> messages).  Then the yasp-scripted command can invoke that command thru 
> sudo, piping the output thru tail again to cut it down to the specific 
> number of lines I have space for, thru cut to cut down the columns to the 
> specific number I have space for... and then posting the result in yasp-
> scripted.

Why only the last 100 lines? Security? But if the user can read the last
100 lines, he can >> them into his log file, and he gets everything. But
maybe I'm getting this wrong.

I have the group set to wheel for the logs I want to be read by trusted

>> Amarok and dolphin at the right are a little small each, but when I use
>> them I just maximize them vertically.
> mpd (using qmpdclient when I'm in kde) for music here, as I didn't like 
> where amarok headed with kde4, and wanted the ability to have the music 
> continue uninterrupted regardless of whether I was in X/KDE or not.  I do 
> miss amarok-for-kde3's visualizations, but not enough to want to deal with 
> amarok's extremely heavy dependencies again (especially now that akonadi 
> works well with sqlite and I've thus been able to remove mysql again), 
> plus amarok for kde4 had done away with visualizations when I left it, 
> while adding all sorts of stupid features I didn't really use or want, so 
> it was simply not a good fit for me any more.  Not that it really /ever/ 
> was, given the dependencies in kde3, as well, even if I tolerated them for 
> the visualizations, etc, at that point.

I sort of like Amarok. It has its bugs, but I see progress, and find it
very convenient. When Amarok took minutes to start, I tried Clementine,
which has the look & Feel of Amarok 1.x, but soon I was missing many
little things. Amarok is geat :)

> And for file management I divide my tasks into sysadmin type tasks (even 
> as a user, config file editing, moving files in general around, etc), 
> where I use the ncurses based mc in either a text VT or a konsole window, 
> doesn't matter, and user type tasks (almost entirely media file handling), 
> for which I tend to use gwenview.  So while dolphin's on my system and it 
> does popup by default when I click on a dir in a folderview or the like, I 
> don't really tend to use it that much, except very transitorily to access 
> some function not particularly convenient directly from a folderview or 
> quickaccess plasmoid.

I also don't use dolphin _much_. But it's convenient to browse through
my MPEG collection, and to sort my music. I can drag files or folders
into Amarok, which won't work with mc. I can delete quickly with the
'Del' key, and have the files still in my Trash [*].
For images I'm using Gwenview or Dolphin. Then this night I tried
Digikam, and investigated this semantic desktop stuff. I don't use that
much yet, but I think it's the way to go. locate is nice, but only when
I know the file name. Sorting files is also good style, I do this, but
this doesn't work too well. Which categories/folders should I choose? I
easily find a specific cartoon in pix/fun/cartoons/<author>. But often
multiple categories apply, and which one should I choose? I have a
folder with pictures of people, and a subfolder with pictures of myself.
But there are also photos of myself in other directories like the one
with images of a holiday.
So I would more like to tell my computer to give me all photos showing
myself. Or showing (me OR my dogs) AND snow. So I tagged some folders of
images, and in digikam this works well.
But not in dolphin. Looks like a bug to me, I can start a search, and I
can shoose from a list of tags I used, but the search does not find
anything. Oh, and now the list of tags is empty. Maybe I have to log out
and in again, I had a crash of nepomuk a while ago.

Oh, these crashes/bugs. Whenever I work for a while with some
applications, I almost always find some bugs. Digikam has a cool diashow
mode, but it only works when I do not use the mouse to switch the image
forth or back. And at this moment it does not work at all, it looks like
my desktop gets in front of the displayed image. Nice idea, but not
useful yet.
Sometimes I have to restart Digikam because of a refresh problem, when
thunbnails flicker and become invisible. And there's a bug in the
context menu for the tag view at the right - when I move the mouse down
the menu, all images become deselected. Quite annoying after I markes
some dozends in a folder with hundreds of files. No big deal, the 'New
Tag' entry in the menu is right at the top, but still, these little bugs
are really annoying, there are so many of them. I just installed a new
version of digikam, let's see if this fixed, or if I have to file a bug
report. I'm doing this quite often, and wonder why I have to do so,
don't the progammers use their own software or what?

[*] Doesn't KDE4's Trash suck? It's nice that it is probably not much
more than a regular folder, so I can work with files in the trash as
with others, or I can open directories I deleted - Windows XP does not
allow this, I have to restore a trashed folder in order to look into it.
But in Windows I can sort by date of deletion, or by size - sorting by
size only works for files in dolphin, not for directories. Sure, that's
how it works, ls only tells you the size the directory needs to hold the
file names, you need du -s for the full size of the directory tree. But
I think that a trash folder should have the function to store this
somewhere when a file is deleted. It's an information that is of much
value to me. Windows has it, why don't we?

>> Oh, and just antoher problem happened: KDE crashed (this happens on a
>> daily basis now, not sure what is responsible for that, I see nothing in
>> Xorg.0.log)
> Interesting.  I'm running about as stable as they get, ATM, typically a 
> week between reboots, no issues, and it'd be more than that if I wasn't 
> kernel testing, etc.

I tried xorg-server 1.7, 1.8 and 1.9, with and without that gallium
stuff for the radeon driver. Well, with gallium opengl was realy really
slow, and I got no visible text consoles (right after I enter my LUKS
passphrase whils still in initramfs, the screen goes blank and comes
back when kdm starts). And without, I got these KDE crashes at least
once per day. So I'm using the closed-source ati-drivers again now. They
sort of work, although I get lots of kernel error messges in syslog. But
at least I do not have those memory problems I had with an earlier
version, so this is okay for the moment.

>> Hmm, I read something similar I think. Don't know what to think about
>> this. And I don't know it this whole activity thing is something for me.
>> Looks to me this is more for people who do not use many virtual
>> desktops. But I think I will add another one just for fun, and who
>> knows, maybe I find useful applications.
> I think it makes the most sense for people who really do use their laptop 
> in multiple locations/senarios, work related stuff at work, traveling home 
> on the train watching a movie, at home doing non-work browsing, etc, and 
> doing demos or troubleshooting when at a client's.  Think of that linked 
> to a GPS or network location sensing logic, so it's automatically open to 
> the apps you use in that context, every time you open the lid!
> But as with you, it doesn't seem to make all /that/ much sense for me, 
> either, tho of course the most interesting uses are often the ones we 
> can't predict until we stumble upon them, and this technology will 
> certainly open up lots of new opportunities for doing just that, so who 
> knows?

I'm curious how all this will evolve.

BTW, is there _any_ documentation on how to use this? I know some people
who don't have a clue what this is for. The plasma handbook has half a
page about activities, but real life examples would be nice.
Well, not for me, I think I know what this is about, but I read some
articles in blogs and am not a new user.

> Meanwhile, I've been rather unhappy about how the preserved-libs stuff is 
> going.  I'd rather let revdep-rebuild handle it in most cases, as having 
> packages own files they don't create upon rebuild can be problematic, and 
> there's various other issues.  But even with FEATURES=-preserved-libs, in 
> fact, apparently /because/ I have that off in some cases, a lot of 
> installs force-keep a library around, mentioning in the log what specific 
> library I need to tell revdep-rebuild to look for now, since the files 
> still there and revdep-rebuild thus can't spot the problem automatically.  
> AUTOMATED REBUILD SYSTEM, forcing me instead to manually read the logs and 
> delete the files that shouldn't be there anyway as they belong to OLD 
> versions of the package, so revdep-rebuild can again automatically spot 
> the outdated links and rebuild the affected packages, without me having to 
> worry about jumping thru hoops detailed in the package logs.  I can see 
> being a bit cautious for things like gcc libs, etc, but there's definitely 
> a whole lot more of these things I'm having to deal with than the number 
> of really toolchain critical libs on the system, as demonstrated by the 
> fact that I can almost always simply manually remove the file and let 
> revdep-rebuild handle the detection and rebuilding automatically, as it 
> SHOULD be doing in the first place and as it USED to do just fine, before 
> people started trying to solve a problem that with certain noted 
> exceptions, doesn't exist on a sane system with --as-needed (now the 
> default), anyway.

Hmmm. I thought the big benefit of preserved-rebuild is that when a
library is upgraded from version A to B, B ist installed, but A is kept,
so all stuff that links to A still works. That is what I thought to be
the biggest problem with Gentoo, that an upgrade of an important library
(like libexpat) breaks much stuff, until this stuff is rebuilt. What if
I need this stuff before it is recompiled? Now, this no longer happens.
And doesn't emerge @preserved-rebuild delete A after it is no longer needed?

Summary: KDE4 still feels not yet ready, has many little problems, and I
wonder why. But it is usable, X doesn't crash any more, and overalll I'm
a happy KDE user again.

This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list