Kickoff menu blank

Duncan 1i5t5.duncan at
Sat Aug 14 10:08:17 BST 2010

dhave posted on Sat, 14 Aug 2010 00:49:10 -0400 as excerpted:

> More data:
> Just now when I tried switching the K menu from classic to kickoff
> (right click on K icon), I left open the console that was giving me
> screen output. Here's the screen output each time I attempt this:
> ==== begin screen output ====
> QGraphicsLinearLayout::removeAt: invalid index 0
> plasma-desktop(6334)/libplasma
> Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0)
> ==== end screen output ====
> Is this significant?

That could be.  I don't get any output here.  The best comparison, 
however, would be with someone else running your distribution and kde 
version, not someone running a different one.  (I run gentoo; you run 
arch.  I'm on 4.5.0; you're on 4.4.5.)  It could well be distribution 
patches that cause that output but that it appears on normally working 
installs, too.  Or it could be that the "useless" output was simply 
removed for 4.5.

I'd try on the arch lists/forums/whatever and see if I could get a 
comparison run from someone else running your kde version but with a 
working kickoff.  Also, it'd be best to have as near to the same config as 
possible, which in practice, means both of you try the new-user or moved 
~/.kde trick, so all the plasma applets are default.  By diffing the two 
outputs, you can then eliminate the lines that are identical between them.

At that point, you can probably file a bug, as you're not likely to get 
much closer as a non-dev user (which I am too).  I probably won't be able 
to help much further, but I'd love to see what lines you get that he 
doesn't, out of curiosity.  And when you file a bug, post the link to it 
too, as I'll likely either CC myself or simply track it for awhile on the 
web, to see what the informed opinion is.

As to whether to file the bug with kde or arch, I don't know what to tell 
you...  Since it's not the leading edge version, probably with arch is the 
way to go first.  How long is it likely to be until an arch 4.5 version is 
available?  If it's only likely to be a week or so, maybe it's worth 
waiting and trying the 4.5 before bugging.  And if it's still an issue 
with 4.5, then a direct kde bug is looking more reasonable.

Oh, and you said you're running 4.4.5 now.  Had you tried previous 4.4.x 
versions, and did they have the problem?  (Presumably not, if you tried 
them, but...)  If it worked with earlier 4.4, the problem must have been 
introduced recently.  It could still be some system library mismatch (a 
distribution issue, not kde's fault), but if it /was/ a problem introduced 
within the 4.4 stable series, it becomes much more interesting, because 
they're normally much more cautious with the micro-versions (4.4.x) than 
with the minor versions (4.x), which means if the issue was introduced in 
that period, even if it was inadvertently fixed in 4.5, it's worth knowing 
about, to keep a similar thing from happening in the stable series once 

Duncan - List replies preferred.   No HTML msgs.
"Every nonfree program has a lord, a master --
and if you use the program, he is your master."  Richard Stallman

This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list