Compositing problems

paulo paulo.jnkml at
Tue Nov 24 13:50:34 GMT 2009

Hi people,

(on kde4.3 - compiled from source with nvidia drivers)

My kde 4.3 env, has been working normally since I compiled it. I'm 
actually very satisfied. Much better than version 4.2.

Unfortunately, I just restarted my laptop and, don't know why, the 
compositing functionality was turned off.
I tried to turn it back on, (alt+shift+F12) nothing.

On "Desktop Effects - System Settings" tried to turn it back on by 
clicking the suspend/resume button, and again nothing, altough it did 
say composing enabled. I should have known since it does not even enable 
the "Apply" button.

So, by disabling and enabling desktop effects "Apply" gets enabled, and 
after clicking it, I got something like "failed to enable composting at 
least with your current settings"... Not very informative. Also, a 
message popped up saying that it had failed to enable all the effects 
that I have selected. (minimizing animation, window open animation, etc.)

Then I tried to restart the computer, with no effect. Tried to check the 
driver, it could have changed somehow, but no, the driver was still 
nvidia closed source binary. Tried a few applications that use opengl, 
textures, blending, everything ran normally.
Glxinfo states direct rendering enabled.
Then I tried to select xrender, and it finally enabled the desktops 
effects, but super slow...

Then I tried to select the OpenGL driver again, no luck, it always gives 
an error, and gets me back to the previous xrender config.

Finally, I noticed the "Disable functionality checks" which got me 
wondering what it was. I click on it, and "Apply" and "OpenGL" and bam! 
That did the trick. Desktop effects back working nice and fast.
So if you have the same problem, just try to click that wonderful box, 
maybe it will help.

Now, what I don't know why I never needed that, and now all of the 
sudden I do. I haven't changed anything since I compiled kde.
I'm still using nvidia-drivers-180.44 (time to change...), it was 
working just perfectly but all of the sudden after a reboot it was gone?!?!?
I smell buggg. Where? I don't know.

This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list