Can't compile extragear/multimedia/k3b on Fedora 11 (SOLVED)

Steven P. Ulrick junk at
Sun Jun 21 22:18:31 BST 2009

On Sun, 21 Jun 2009 15:55:57 -0500
"Steven P. Ulrick" <junk at> wrote:

> BUT, KCddb is not listed in extragear/multimedia/k3b/INSTALL at all.
> It is not listed as a REQUIRED or an OPTIONAL dependency.  So,
> cmakekde says that it is required, INSTALL does not say either way
> (so we would assume that it is NOT required.  But, k3b seems to not
> be building on my system because of this.
> In closing, the question arises, are you or anyone else on this list
> able to build k3b from extragear in the same path as a KDE SVN TRUNK
> install?  I would most like to hear from other Fedora users that
> either are able or unable to do so.
> Anyway, thank you for you help so far, and I will be looking forward
> to doing what I can to help get this issue solved.  Realizing of
> course that it is possible that I am the only one with this problem...

Hello James
First of all, thank you for your help.  After I finished my last email
on this subject, I went looking around in kdemultimedia.  While there I
discovered an edited CMakeLists.txt file in the kcddb subdirectory.  I
didn't bother checking to see what I had done to the file.  What I did
do is remove that file and run svn up kdemultimedia.  I then ran
"cmakekde" in kdemultimedia.  At which time the file that I needed all
along was finally on our system.  Then I did svn up on
extragear/multimedia and then ran cmakekde in k3b.  So, now I have k3b
from extragear running on our system.

I will never know, of course, but I assume that I must have set kcddb
to not be build because of issues that I may have been having with
building kdemultimedia.  Possibly it then just bit me when I tried to
compile something that depended on it.

In any case, problem solved :)

Steven P. Ulrick
This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list