Plasma::Applet::setBackgroundHints ARGH!

James Richard Tyrer tyrerj at
Sun Jul 19 00:45:29 BST 2009

Would "setBackgroundHints" is the wrong name for the function (OOP = 
method IIUC) be considered to be a bug?

IMHO, it should be called "setBackgroundType".  Perhaps Canadian really 
is a different language. :-)

Problem is that I am looking for "setBackgroundAttributes" but thought 
that hints might be it.

There needs to be a per widget configuration setting for widgets that 
use a translucent background so that it can be controlled like it is in 
KDE3.  The fact that this is missing is a serious usability issue in 
FolderView.  It is nice to have the translucent background, but you do 
need to be able to read the names of the folders and/or files.

Is there a bug for this yet?

James Tyrer

Linux (mostly) From Scratch

This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list