K3b (extragear) cannot create audio CD from mp3 files: plugins have dissappeared

Steven P. Ulrick lists-kde at afolkey2.net
Thu Aug 27 01:52:26 BST 2009

> On Wed, Aug 26, 2009 at 4:12 PM, Steven P. Ulrick<lists-kde at afolkey2.net> 
> > Hello Everyone
> > I have been compiling & installing KDE from Branch 4.3 SVN for a few months 
> > I have also been taking the risk of compiling & installing a number of items
> > from extragear & playground, k3b being among them.
> > K3B has been compiling perfectly for quite a while now.  I have been burning
> > Data & Audio CD's from K3B (from MP3 files) with no problems at all.
> > Now, all of a sudden I have started getting this message:
> >
> > Mp3 Audio Decoder plugin not found.
> > K3b could not load or find the Mp3 decoder plugin. This means that you will 
> > be able to create Audio CDs from Mp3 files. Many Linux distributions do not
> > include Mp3 support for legal reasons.
> > Solution: To enable Mp3 support, please install the MAD Mp3 decoding library 
> > well as the K3b MAD Mp3 decoder plugin (the latter may already be installed 
> > not functional due to the missing libmad). Some distributions allow 
> > of Mp3 support via an online update tool (e.g. SuSE's YOU).
> It may be looking in a different place for the libraries instead of
> /usr/local/kde4/lib/kde4/. You might try to symlink those affected k3b
> files from there to /usr/lib and see if that fixes it.

Hello Paul
Are you implying that k3b from extragear/multimedia compiled under Branch 4.3 
KDE from SVN will look for plugins in /usr/lib?  I just want to know for sure.  
I did try what you suggested, and even deleted all k3b related items in ~/.kde.
I had no success.

But after I did all that, I had an idea.  So I tried the following:
I logged out of my main user account ($KDEDIR=/usr in that account) and logged 
into the account of the user that I built Branch 4.3 of KDE under.  I ran k3b 
from that account, and the plugins show up as desired.

Should the extragear/multimedia version of k3b (build under a different $KDEDIR) 
work for me the way that it has been?  Possibly or probably not.  But I still 
wonder, why did it work for me for so long? (logged in as a user that has 
$KDEDIR set to /usr)  And is there anything I can do to make it work the way 
that it used to?

Steven P. Ulrick
This message is from the kde mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

More information about the kde mailing list