Battery Monitor Plasmoid not giving warnings

Duncan 1i5t5.duncan at
Fri Aug 21 19:54:56 BST 2009

Dotan Cohen posted on Fri, 21 Aug 2009 11:23:05 +0300 as excerpted:

>> Another thing, is "Battery Charge" listed in the "Sensor" tree in
>> KSysGuard? I seem to have this under: "Advanced Power Management"
>> despite the fact that I do not have a laptop. :-| This indicates
>> that I have 0 charge which may be logical since I don't have a
>> battery, or it may indicate that this is the default.
>> I would think that having it show up in KSysGuard would be a necessary
>> condition for the widget to function but perhaps not.
> Is that what is now called System Monitor? That is what I get when I run
> the command ksysguard in Konsole (KDE 4.3). It does not have an
> "Advanced Power Management" tab or option, and I cannot find a Sensor
> Tree nor Battery Charge anywhere. I suspect that these have not been
> ported over from KDE 3.x.

Yes, ksysguard is now called "System Monitor" by window title (the 
executable name is still ksysguard).  You may have it by one or the other 
title in your kmenu (assuming it's set to display title, not function), 
and editing it should confirm the executable filename.

I guess I'm a traditionalist.  I much prefer titles to generic functions 
(tho I base my frequently used hotkeys in generic functions, so I can 
change the app without changing the hotkey, if I need to), and I much 
prefer that the title matches the executable name, as well, so I actually 
know what I'm running, and can invoke it from the command prompt equally 
to the menu, without having to try to figure out how they correspond to 
one another.  Having the function and/or short description as a tooltip 
is fine, but that's what it should be, a tooltip, or on the newer menu 
styles and in krunner, a decidedly smaller font secondary label.

Meanwhile, some of the 2.6.31-rc kernels don't have working sensors.  
That was one of several kernel bugs I've reported this round, but it's 
fixed in rc-6 and IIRC rc-5 as well.  But if you can run sensors at the 
text prompt and get a normal listing, that's not your problem, lm_sensors 
is fine in that case, and it's kde not picking them up.

But ksysguard has picked them up fine for me, with both kde 4.2.4 and now 
4.3.0.  I was missing network in 4.2.4 but that's fixed for 4.3.0 (I read 
the note for that commit somewhere along the line as well too), and /
some/ disk activity seems to work now, tho the md/RAID doesn't.  It's 
listed, but with "dummy" ksysguard sensors.  But it worked in 3.5, and 
with the network being fixed, it seems there's still active development 
going on to bring it back to the 3.5 level. (Umm, as we regulars know by 
now, that's a sore spot, especially when kde seems to be dumping 3.5 
support before 4.x even does what 3.5 did in many such areas.)

But I don't have anything battery listed.  I'm guessing that requires 
ACPI settings that I have turned off in my kernel, as I'm running a wall-
powered desktop.  If you're interested, I can post the kernel menuconfig 
entries I think it is.  I do NOT think most battery sensors are 
lm_sensors based, but ACPI.

Duncan - List replies preferred.   No HTML msgs.
"Every nonfree program has a lord, a master --
and if you use the program, he is your master."  Richard Stallman

This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list