Konq or linux dns problem

John john_82 at tiscali.co.uk
Fri Sep 21 17:49:12 BST 2007

On Friday 21 September 2007 15:41, Boyan Tabakov wrote:
> On Friday 21 September 2007 17:05:32 John wrote:
> > Hi
> > Think I've been here before but this started happening a couple of weeks
> > ago.
> >
> > Many web pages are sloooooooooooooow ever so slow. Looking with ethereal
> > a dns request is sent out to tiscali's primary dns server. No reply for 5
> > secs so the secondary is tried and the address comes back within 25mSec.
> > I have my router set to use the tiscali numbers - and 67.
> > 67 is the secondary. I've switch the addresses round in the router to use
> > 67 first but the system still uses 66 first. Me thinks something in my
> > system is doing this and not using the router as it should.
> >
> > The router is a draytek vigor 28000. (adsl 2+ ready.)
> >
> > Any comments? How can I fix it. Pages can take ages to come up as lots
> > use source from many many servers. Bit like the ipv6 problem from a while
> > ago.
> >
> > The problem may have come about because of a suse upgrade. I've had a
> > simular problem with a router that would automatically detect the dns
> > server. It looked like some web tracker was spoofing it which is why I
> > put the addresses in the router.
> What is your resolv.conf configuration file on your desktop? Is your
> desktop using the router as a DNS resolver?  Your router might use the two
> DNS server IP addresses in a round-robin and not always trying the primary
> first.
> Why don't you set only one DNS server address?
> You can always set up your own resolving DNS server on the desktop machine
> and forget about the tiscali resolvers...

The only resolv.conf file I can find is in /etc and it shows 66 first and then 
It states "placed there by dhcpcd and that it's temporary and will be replaced 
later."  Also some instructions on how to stop dhcpcd from changing it which I 
should be able to follow.
There's also a same named shell script in 

I changed the order in /etc/resolv.conf and things are now much quicker. 
Tiscali.co.uk still takes about 45 secs to load completely though but that 
seems to be entirely down to them. Line speeds are more or less what I am 
paying for. Usually about 1.8 or more Mb/s.

I would much rather have a set up where the router did the dns look up but 
have no idea how to force it. I'm sure it has worked that way in the past and 
that the routers have always tried the primary dns I've set 1st.


Suse 10.0
KDE 3.4.2 B
This message is from the kde mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

More information about the kde mailing list