Unable to start up KDE due to hanging with a black desktop and movable mouse cursor.

Phillip Pi ant at zimage.com
Mon Nov 19 09:28:13 GMT 2007

> > $ ping $HOSTNAME
> > PING localhost.localdomain ( 56(84) bytes of data.
> > 64 bytes from localhost.localdomain ( icmp_seq=1 ttl=64
> > time=0.061 ms
> > 64 bytes from localhost.localdomain ( icmp_seq=2 ttl=64
> > time=0.048 ms
> >
> > --- localhost.localdomain ping statistics ---
> > 2 packets transmitted, 2 received, 0% packet loss, time 999ms
> > rtt min/avg/max/mdev = 0.048/0.054/0.061/0.009 ms
> Good.
> > So yes. And in case you got confused with the list of IP addresses and
> > domain names in the log -- it is because I have a hosts file that blocks
> > bad sites. I tried removing it and retrying KDE. It made no differences.
> No, I got that :)
> This was based on the last few lines, where it gets "Connection refused" on 
> a couple of times.
> Hmm, can you echo $DISPLAY in startkde right before ksmserver's line?

I assume like this:
# We only check for 255 which means that the ksmserver process could not be
# started, any problems thereafter, e.g. ksmserver failing to initialize,
# will remain undetected.
test -n "$KDEWM" && KDEWM="--windowmanager $KDEWM"
kwrapper ksmserver $KDEWM 
echo $DISPLAY > /home/ant/download/display.txt
if test $? -eq 255; then
  # Startup error
  echo 'startkde: Could not start ksmserver. Check your installation.'  
  xmessage -geometry 500x100 "Could not start ksmserver. Check your 

If so, then:
$ more /home/ant/download/display.txt 

> Another thing you could try is to start just xterm and then run startkde 
> inside it, i.e.
> startx /usr/bin/xterm
> Should start the X server and just xterm as the only window. You'll need to 
> move the mouse cursor over the window to allow keyboard input.

That worked, but no cigar. I see KDE's splash screen loader and it
blinks at the first icon (wheel) with "Setting up interprocess
communication" like I did in Gnome. After a minute or two, this splash
screen goes away and xterm is still showing "startkde: Starting up..."
Here's a strace from second attempt inside xterm:
http://pastebin.ca/783688 (looks the same). Does startkde have a debug

I am going to bed now, so I will try more later from your ideas. :)
"One day he sprained an ankle rather than crush an ant." --Les 
 / /\ /\ \       Phillip/Ant @ http://antfarm.ma.cx (Personal Web Site)
| |o   o| |         Ant's Quality Foraged Links (AQFL): http://aqfl.net
   \ _ /                 E-mail: philpi at earthlink.net or ant at zimage.com
    ( )
This message is from the kde mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

More information about the kde mailing list