USB drive automount successfully, but cannot open folder

Jim MacLeod j75trym at
Fri Jan 5 18:43:56 GMT 2007

Franklin wrote:

> Hi, list.
> I posted this question to KDE forum, but still couldn't get answers after
> some discussion.
> When I plug in my USB drive, it was mounted automatically.  Then KDE tried
> to open the mount point folder with kio_file, and replied an
> "/mnt/removable is a folder, but a file was expected." error message.
> I tried hard to find where the setting is, but in vain.  I also hacked
> into the kdelibs/kio code and inserted some debug messages.
> Could anybody please give me some hints about:
> 1. How could I modify the behavior when USB plug in, change from "opening
> folder" to "Do nothing"?

Don't know if it's relevant but I think these actions are saved as .desktop
files in /usr/share/apps/kde/konqueror/servicemenus on my Kubuntu system.

> 2. Why does KDE use kio_file to launch the mount point folder?  I cannot
> find
> where the behavior is defined.  Is it a bug or just misconfigured?
> Thanks for you help.
> Regards,
> Franklin
Hope that helps

This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list