libtool: link: `/usr/lib/' is not a valid libtool archive

Steven P. Ulrick lists-kde at
Thu Mar 23 22:33:59 GMT 2006

Hello, Everyone
I am compiling and installing KDE from SVN (Branch 3.5) on Fedora Core
5.  All is going perfectly, except the following:

linking ./kopete/plugins/nowlistening/
/bin/sh ./libtool --silent --mode=link --tag=CXX g++ -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts -Wall -W -Wpointer-arith -g3 -fno-inline -Wformat-security -Wmissing-format-attribute -Wno-non-virtual-dtor -fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION -I/home/kdefc5/CVS/KDE-SVN/kdenetwork/kopete/libkopete -I./kopete/libkopete -I/home/kdefc5/CVS/KDE-SVN/kdenetwork/kopete/libkopete/avdevice -I/home/kdefc5/CVS/KDE-SVN/kdenetwork/kopete/libkopete/ui -I./kopete/libkopete/ui -I/usr/local//include -I/usr/local//include/xmms -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/local/kde-svn-fc5/include -I/usr/local/qt-src/include -I. -DQT_THREAD_SUPPORT -D_REENTRANT -D_FILE_OFFSET_BITS=64 -module -avoid-version -module -no-unde
 fined -Wl,--no-undefined -Wl,--allow-shlib-undefined -R /usr/local/kde-svn-fc5/lib -R /usr/local/kde-svn-fc5/lib -R /usr/local/qt-src/lib -R /usr/lib -rdynamic -L/usr/local/kde-svn-fc5/lib -L/usr/local/qt-src/lib -L/usr/lib -o ./kopete/plugins/nowlistening/ -rpath /usr/local/kde-svn-fc5/lib/kde3 ./kopete/libkopete/ -L/usr/local//lib -L/usr/lib -lgtk -lgdk -lgmodule -lglib -ldl -lXi -lXext -lX11 -lm -lxmms ./kopete/plugins/nowlistening/nowlisteningconfig.lo ./kopete/plugins/nowlistening/nowlisteningplugin.lo ./kopete/plugins/nowlistening/nlkscd.lo ./kopete/plugins/nowlistening/nlnoatun.lo ./kopete/plugins/nowlistening/nlxmms.lo ./kopete/plugins/nowlistening/nowlisteningguiclient.lo ./kopete/plugins/nowlistening/nljuk.lo ./kopete/plugins/nowlistening/nlamarok.lo ./kopete/plugins/nowlistening/nlkaffeine.lo
grep: /usr/lib/ No such file or directory
/bin/sed: can't read /usr/lib/ No such file or directory
libtool: link: `/usr/lib/' is not a valid libtool archive
Error creating ./kopete/plugins/nowlistening/ Exit status 1.

I deleted kdenetwork/kopete and did "svn up kdenetwork" and then
proceeded to recompile.  Same error.  If I delete "kopete" from
"kdenetwork/subdirs" and save that file as "kdenetwork/inst-apps" and
Then recompile, kdenetwork will then finish compiling.

I got the same error compiling kdeutils.  In that case, it bailed while
compiling "superkaramba"  Again, removing that directory and following
the procedure outlined in the above paragraph resulted in EXACTLY the
same result: I had to delete "superkaramba" from "subdirs" and resave
that file as "insta-apps" to get kdeutils to build.

This is a fresh install of Fedora Core 5 (done just last night.)  The
Fedora project has eliminated the "Install Everything" option, which I
always used to use, so it's quite possible (actually likely) that the
fault lies with Fedora.  I have ran "yum install" to install everything
that either begins with gtk or contains gtk in the middle of the name.
This has not fixed the problem.  Also, the offending /usr/lib/
does not seem to exist anywhere on my system.  I would have tried just
making a symlink to whereever it was located, since this has worked
with a few issues that I had with Fedora Core 3.

If this is a Fedora packaging issue, please let me know so that I can
take this up with them.

Have a Great Day,
Steven P. Ulrick
This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list