Compiling kdebase 3.4.2 with LDAP support

Gianluca Varisco giangy at
Tue Apr 11 13:07:40 BST 2006

Lars Stolze wrote:
> Hello,
> I'm having serious problems compiling KDE with LDAP support. I'm
> running Slackware 10.2 with the default 2.4.31 kernel and a default
> KDE 3.4.2 installation. I always use checkinstall 1.6.0 to install
> self-compiled stuff.

Hi Lars,

I'm using too Slackware (with -current tree updates) but the better way 
(for me and for other slackers) is to use SlackBuild instead 
checkinstall, specially for complexes packages.

> At first I installed OpenLDAP using the openldap-2.3.20-i486-1kjz.tgz
> package from and tried to compile kdelibs and kdepim
> with LDAP support as suggested in a lot of posts across the web.
> Because there were no configure flags concerning LDAP in kdelibs and
> kdepim but in kdebase, I went on and tried to compile kdebase instead.
> Unfortunately compiling kdebase results in an error message. I thought
> that might be related to the OpenLDAP package from
> and therefore I compiled OpenLDAP 2.3.20 myself using:
> ./configure --prefix=/usr/local/openldap --localstatedir=/var/lib
> --sysconfdir=/etc --with-cyrus-sasl --with-tls --with-readline
> --with-threads --enable-debug --enable-syslog --enable-dynamic
> --enable-local --enable-proctitle --disable-ipv6 --disable-static
> --enable-shared --disable-slapd --disable-slurpd
> make depend
> make
> checkinstall

 From openldap-client.SlackBuild:

./configure \
   --prefix=/usr \
   --localstatedir=/var/lib \
   --sysconfdir=/etc \
   --with-cyrus-sasl \
   --with-tls \
   --with-readline \
   --with-threads \
   --enable-debug \
   --enable-syslog \
   --enable-dynamic \
   --enable-local \
   --enable-proctitle \
   --disable-ipv6 \
   --disable-static \
   --enable-shared \
   --disable-slapd \

make depend
make -j3
make test
make install DESTDIR=$PKG

- cut -

for more informations.

Hint: On 04/08/2006 at 06:02:00 PM was released OpenLDAP 2.3.21. The 
list of changes is available at

> That works fine so far. After that I tried to compile kdebase using:
> ./configure --prefix=/opt/kde --with-shadow --with-xinerama
> --with-ldap=/usr/local/openldap --program-prefix=""
> --program-suffix=""
> ./configure works, but running make finally resuls in:
> Making all in ldap
> make[3]: Entering directory
> `/home/lstolze/Downloads/kdebase-3.4.2/kioslave/ldap'
> if /bin/sh ../../libtool --silent --tag=CXX --mode=compile g++
> -DHAVE_CONFIG_H -I. -I. -I../.. -I/opt/kde/include
- cut -
> Because I supposed there may be a problem with the latest OpenLDAP
> release I also tried the whole process with a self-compiled OpenLDAP
> 2.3.6 which was released last summer before the release of KDE 3.4.2.
> Unfortunately the result was the same. After that I compiled OpenLDAP
> version 2.2.27. 

Have you tried with the latest version of KDE? You can modify the
official SlackBuild (kdebase.SlackBuild) with --with-ldap directive in 
the configure, but i think you don't need this.

for more informations.

> Compiling kdebase worked fine then, but the
> installation failed during make install, respectively checkinstall.
> There was a problem finding and copying a file called
> There were only files called kio_ldap.lo and present.
> Sorry, but I haven't copied the error message and don't remember the
> exact wording.

With the official packages for Slackware 
( I have a 
file called

giangy at lab:~$ spi -s kio_ldap
Match found in package: kdebase-3.5.2-i486-1
SECTION: slackware

> It would be great if someone could help me with that. I need LDAP
> support for the Groupware at work, but have no idea what to try next..
> Thanks a lot.
> Lars

Try with official precompiled packages + openldap-client (2.3.20 version 
from slackware -current tree or 2.3.21, the latest version) :-).

Best Regards,

Gianluca Varisco

-- Research Lab - giangy at

This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list