Non-KDE apps can't connect to web sites using URLs

nigel henry cave.dnb at
Wed Oct 5 10:01:57 BST 2005

On Tuesday 04 Oct 2005 8:11 pm, Jeffrey Barish wrote:
> Nigel Henry wrote:
> > On Monday 03 October 2005 10:03, Jeffrey Barish wrote:
> >> Nigel Henry wrote:
> >> > On Sunday 02 October 2005 19:05, Jeffrey Barish wrote:
> >> >> Jeffrey Barish wrote:
> >> >> > I know that this sounds bizarre, but since I upgraded my system
> >> >> > from Libranet 2.8 (2.4 kernel) to 3 (2.6 kernel, KDE 3.3.2), it
> >> >> > appears that only KDE applications are able to connect to Internet
> >> >> > sites using URLs. I have three non-KDE applications (Firefox,
> >> >> > Moneydance, Epiphany (web browser)) that fail to connect using URLs
> >> >> > and four KDE applications (Konqueror, KMail, KNode, KNewsTicker
> >> >> > that succeed. Firefox and Epiphany
> >> >> > are able to connect using IP numbers.  The fact that IP numbers
> >> >> > work suggests a DNS problem, but DNS lives at my ISP so I don't see
> >> >> > how it would
> >> >> > be able to discriminate against only certain apps.  Well, I don't
> >> >> > see how
> >> >> > anything would.  Is there anything in KDE that might account for
> >> >> > this favoritism?
> >> >>
> >> >> It seems that my /etc/resolv.conf has the entry
> >> >>
> >> >> nameserver
> >> >>
> >> >> which corresponds to my gateway.  It also has an entry for the
> >> >> correct nameserver.  When I delete the one for my gateway,
> >> >> applications other than
> >> >> KDE work.  Isn't KDE clever to overlook this misdirection?  Now, if I
> >> >> could just figure out why resolvconf is inserting this erroneous
> >> >> entry, I will finally be done with this problem.
> >> >
> >> > Hi. I presume that each time you boot up the Libranet machine, your
> >> > gateway IP address is turning up in /etc/resolv.conf. Have you tried
> >> > booting up the machine while unplugged from the network? Does the
> >> > gateway address still turn up in /etc/resolv.conf ? What OS do you
> >> > have on the gateway machine connected to the Internet? I've got KDE
> >> > 3.3.2 on my Debian boxes, and notice in control centre/KDE
> >> > components/Service manager there is a start up service named "KDE
> >> > Internet Daemon" . Whether that has anything to do with why the KDE
> >> > apps work but the others don't, I don't know. Nigel.
> >> > ___________________________________________________ This message is
> >> > from the kde mailing list.
> >> > Account management:
> >> > Archives:
> >> > More info:
> >>
> >> Yes.  I have to delete the bogus entry every time I reboot.
> >>
> >> I tried booting while unplugged from the network.  I get no entries at
> >> all
> >> in /etc/resolv.conf.  The gateway is a DSL router (Actiontec).  There is
> >> no KDE Internet Daemon in my Control Center/KDE Components/Service
> >> Manager, so I think we have to rule out that theory.
> >>
> >> Incidentally, when I booted unplugged, not only did the two nameserver
> >> entries disappear, but a third entry "search domain.actdsltmp" also
> >> disappeared.  Don't know where that one is coming from either.
> >
> > Hi. I have no experience with DSL routers as I'm still on dialup using a
> > Linux based Smoothwall Express2 as a firewall/gateway. The entries
> > disappearing when you boot the machine while off the network indicates
> > that you're using dhcp to get IP addresses for you're Libranet box, also
> > the nameserver address. I'm at the moment downloading an enormous 9.1MB
> > pdf for the Actiontec GT704, which no doubt is not yours, but to see if
> > it's possible to set up your machine with static addresses, which would
> > at least solve the problem of dhcp adding this extra entry in
> > /etc/resolv.conf. It may be worth checking the setup of the router,
> > unless you have other machines using it with no problems. It's beginning
> > to look more like a networking problem, rather than something to do with
> > KDE, as I can't see KDE being responsible for importing the
> > address to /etc/resolv.conf. I'll
> > be back!  After reading the manual. Nigel.
> I suspect that you're right, but there is still something KDE-related
> happening.  I have now learned that it is normal for a router to return its
> IP number.  My old OS has the same nameserver entry in its /etc/resolv.conf
> yet no application had a problem with it there.  On my new OS, I get a
> response whether I do "dig <the real DNS server>" or "dig
>".  If dig can get a name resolved by addressing
> a query to the router, then surely Firefox can too.  Something else is
> happening that gets circumvented by deleting the nameserver entry.  And
> every KDE application is already smart enough to avoid the problem in the
> first place.

Hi. I'm sort of down to the straw clutching stage now as I have no hair left 
to pull out. Yesterday I DL'd the Libranet install guide along with getting 
the Actiontec manual. On page 12, section 20.1.4. DNS of the Libranet manual, 
it says you can set the DNS servers manually if you don't want Libranet to 
automatically search for them. Now you've probably tried this, but, if not. 
Go for it. It may be worth also checking in your /home/user directory, and 
see if the .mozilla (hidden file) is there with firefox in it. It may be 
worth a try, to rename that file to something obscure, then start firefox 
again which will generate a new .mozilla file in you're /home/user directory. 
I was just wondering whether upgrading Libranet had failed in some way to 
upgrade these files to use KDE3.2.2 . I just tried this on my Debian install, 
and it does make a new .mozilla file. If you have a load of bookmarks in 
Firefox, export them somewhere first, just in case. If there is no change, 
just delete the new .mozilla file, and rename the original one to .mozilla. 
Also why not DL Opera's webbrowser. . It will be a new 
install to you're Libranet 3.0 with KDE's 3.2.2 desktop, and if it works may 
identify that there was some problem during the upgrade. I see that Opera's 
downloads menu has an entry for "Other/Static DEB" which should be ok for you 
. If you fancy a bit of packet sniffing, you can install Ethereal. It's on 
Debian's repo using aptitude update manager. Not sure what you use for 
updating on Libranet. Using this you can check out which DNS server both 
Firefox and Konqueror are trying to access, and also see where Firefox is 
getting hung up. Also Having studied the manual for Actiontecs USB/Ethernet 
DSL Gateway Model GT704, it is possible to switch dhcp off, and configure 
your machine with a static IP address, not that this is going to fix your 
present problem. All the best. Nigel.

This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list