Konqueror does not show dialog for Java applet

John Zoetebier john.zoetebier at transparent.co.nz
Sat Jul 3 10:22:44 BST 2004

James Richard Tyrer wrote:

> John Zoetebier wrote:
>> John Zoetebier wrote:
>>>This is more specific thread for a Java applet problem with Konqueror 3.2
>>>Use a browser like Mozilla with the Java plugin enabled.
>>>Check this via Help > Plugins : you will see a section for something like
>>>Java(TM) Plug-in 1.4.2_04-b05
>>>Next go to web site http://www.postbank.nl
>>>Under Mijn Postbank.nl click on login.
>>>Wait about 10 seconds and you get a dialog to download a Java Applet:
>>>Warning - security
>>>Do you want to trust the signed applet distributed by "Postbank N.V"
>>>Now do the same with Konqueror.
>>>The Java applet dialog box does not appear.
>>>JavaScript is properly working with Konqueror.
>>>Did anybody manage to get Java working properly with Konqueror ?
>>>If so, what are the settings ?
>> I ran a test with Opera for page
>> https://www.p3.postbank.nl/sesam/SesamLoginServlet
>> After a few seconds Opera shows a dialog with title "Java security" and
>> text:
>> A signed applet is requesting additional privileges. Do you wish to grant
>> this applet all permissions ?
>> There is a view button to for the certificates shown in a list.
>> When I repeat the above with Konqueror I see in the right bottom corner a
>> bug icon.
>> When I click on the icon a dialog appears with title JavaScriptErrors and
>> text:
>> Error: https://www.p3.postbank.nl/sesam/js/sitestat.js: TypeError: Value
>> undefined (result of expression ns_33.addBehavior) is not an object.
>> Cannot be called.
>> It looks like this is not a Java problem in Konqueror but a JavaScript
>> problem.
>> If there is no other explanation I will lodge a bug report for Konqueror.
> This does work for me with 3.2.3 so I wouldn't file a report unless/until
> you have upgraded to that version.
> Another possibility is that it might be related to pop-up window options. 
> I have set the option to open user initiated pop-ups in a new window
> rather than a new tab.

I cannot find pop-up windows options for Konqueror 3.2.
What is the easiest way to upgrade to Konqueror 3.2.3 ?
I tried to upgrade KDE in the past on a SuSE box but got caught in zillions
of dependencies.
At the moment I run Mandrake 10.0.

John Zoetebier

This message is from the kde mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

More information about the kde mailing list