konstruct for 3.3 bails out

Gene Heskett gene.heskett at verizon.net
Mon Aug 23 08:02:24 BST 2004

On Monday 23 August 2004 02:30, Gene Heskett wrote:
>On Sunday 22 August 2004 14:39, Tami King wrote:
>>On Sunday 22 August 2004 12:23 pm, Gene Heskett wrote:
>>> >Add -logg after -lvorbis in the Makefiles will take care of
>>> > this. At least it did for me.  Rex Dieter posted this patch
>>> > on kde-linux when I asked about it there.  I applied it and
>>> > it worked fine the first time I compiled, but after updating
>>> > from CVS I had the problem occur again so I editted the
>>> > offending Makefiles by hand.
>>> Thanks, but...
>>> Makefiles?  Plural?  In other words, its just not the
>>> konstruct/kde/kdemultimedia/Makefile.  Please elaborate.
>>I should have said the Makefile in any directory where linking
>>failed.  Now you are going to make me have to remember what I
>>did.  It was just one I believe in a subdirectory of
>>kdemultimedia.  The configure.in patch should fix all of that,
>>though.  I don't really know why I had to go back and update one
>>Makefile by hand.
>One other detail Tami;  I had to go find a fresher copy of automake
>and rerun aclocal and automake in that directory to get all the
>versions to match again.  The automake I found was 1.9.1, my old FC2
>installed 1.8.7 was spit out by the scripts when they discovered the
>configure.in had been touched.  And it squawked about a bunch of
>stuff being "underquoted" until I stopped it and ran those two utils
>by hand.  But it seems to be happy,  its actually started the
>compiling now.
>Thanks for the bailout, I appreciate it.

But it didn't get very much farther than the oggvorbis stuff,
4 or 5 more modules maybe, and now its died makeing kwidget stuff:

make[5]: Entering directory `/usr/src/konstruct/kde/kdemultimedia/work/kdemultimedia-3.3.0/arts/gui/kde'
if /bin/sh ../../../libtool --silent --mode=compile --tag=CXX g++ -DHAVE_CONFIG_H -I. -I. -I../../.. -I../../../arts/runtime -I../../../arts/gui/common -I/root/kde3.3/include/arts -I/root/kde3.3/include -I/usr/X11R6/include   -DQT_THREAD_SUPPORT -I/root/kde3.3/include -I/usr/X11R6/include -I/root/kde3.3/include -I/usr/X11R6/include -D_REENTRANT  -Wnon-virtual-dtor -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -O2 -I/root/kde3.3/include -I/usr/X11R6/include -L/root/kde3.3/lib -L/usr/X11R6/lib -O2 -pipe -I/root/kde3.3/include -I/usr/X11R6/include -L/root/kde3.3/lib -L/usr/X11R6/lib -O2 -pipe -Wformat-security -Wmissing-format-attribute -fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION -MT kwidget_impl.lo -MD -M
 P -MF ".deps/kwidget_impl.Tpo" -c -o kwidget_impl.lo kwidget_impl.cpp; \
then mv -f ".deps/kwidget_impl.Tpo" ".deps/kwidget_impl.Plo"; else rm -f ".deps/kwidget_impl.Tpo"; exit 1; fi
kwidget_impl.cpp:179:28: kwidget_impl.moc: No such file or directory
make[5]: *** [kwidget_impl.lo] Error 1

A "tree|grep kwidget_impl.moc" in the top level dir comes up empty.

Has anyone encountered this and fixed it?

Cheers, Gene
"There are four boxes to be used in defense of liberty:
 soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
99.24% setiathome rank, not too shabby for a WV hillbilly
Yahoo.com attorneys please note, additions to this message
by Gene Heskett are:
Copyright 2004 by Maurice Eugene Heskett, all rights reserved.
This message is from the kde mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

More information about the kde mailing list