Konqueror Lan Browser not switching to proper protocol

Tako Schotanus quintesse at palacio-cristal.com
Sat Feb 22 22:07:45 GMT 2003

I've got the same problem although it worked before.

Any chance you are using RedHat 8.0 (with a crippled KDE 3.0) and then
upgraded it to KDE 3.1?

That's when all kinds of small error seemed to have crept into my


On Sat, 2003-02-22 at 20:41, Carlos A. Siso wrote:

> El Sáb 22 Feb 2003 14:45, gabriel escribió:
> > On February 22, 2003 12:18 pm, Carlos A. Siso wrote:
> > > Greetings.
> > >
> > > I do not know if this has been previously reported. Anyway, in konqueror
> > > lan browser for KDE 3.1 (Redhat 8.0), when clicking the SMB or FISH sub
> > > folder of a networked equipment (lan://localhost/machine.domain.com),
> > > konqueror try to open the folder "lan://localhost/machine.domain.com/SMB"
> > > (lan://localhost/machine.domain.com/FISH) and does not show anything. If
> > > you point konqueror directly to "SMB://machine.domain.com" it shows the
> > > available SMB share points on "machine.domain.com"
> >
> > i've heard that you need to use "rlan:/" instead of "lan://" (note the
> > single slash).  i tried it out and it worked.... badly.  the cascading look
> > wasn't there, and the folders weren't appearing as a "sub" of any others...
> > over all very messy...  but it *sorta* worked...
> Weird!. I Tried "rlan:/machine.domain.com" and it shows the SMB, FISH etc. 
> folders. But if I click on SMB it open "rlan:/machine.domain.com/SMB" (same 
> problem as "lan://").
> One thing I note is that on machines with a Web Server (HTTP), clicking on the 
> HTTP icon does not try to open "lan://machine.domain.com/HTTP" as it does 
> with SMB folders, but switch to the http:// protocol 
> (http://machine.domain.com) correctly (both lan:// and rlan:/). After some 
> test I found that HTTP y FTP  folders works OK while SMB, FISH y NFS folders 
> fails to switch to proper protocol. Could it be a problem related to missing 
> MIME types and/or definitions?
> Thanks,

Tako Schotanus <quintesse at palacio-cristal.com>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde/attachments/20030222/63b8623a/attachment.htm>

More information about the kde mailing list