how to set character encoding in kcontrol ?

James Richard Tyrer tyrerj at
Tue Dec 23 21:06:01 GMT 2003

Martin Koller wrote:
> Hash: SHA1
>>>Before those upgrades, I could see the EURO sign e.g. when I type here in
>>>kmail, but now I don't (do you see something if I type 3 times EURO "€€€"
>>Yes, three EuroSigns.
>>Did the EuroSigns in my e-mail show up OK on your system?
> Huch - I now see the EUR signs in the mail composer as I reply to your mail 
> now ...
> I found out, that this is due to the font _size_ I selected.
> If I select Courier [Adobe] 10 points, I see the EUR sign.
> If I select 9 points, I don't.
> Any ideas how this can be?
Courier [Adobe] that comes with XFree86 is a bit mapped font.  Try IBM Courier or 
BitStream Courier which are scalable Type1 fonts.

> Hmmm ... I think I do too much playing with the font stuff.
> I have again upgraded to Xfree86-4.4 RC2, and have now only the Xfree fonts 
> installed. Now I don't have the Courier [Urw] font anymore, but only
> Courier from Adobe Bitstream or Cronyx.
>>>I just have some empty space). I use the font Courier [Urw], which
>>>definitely has the EURO sign in Table 32 using kcharselect as you said -
>>>but: Using kcharselect shows me the EURO sign in the table-view, but if I
>>>click on the EURO sign, I get _nothing_ in the Textfield below, where
>>>normally all the chars clicked on are pasted.
>>>Any ideas what I'm doing wrong ?
>>This is seriously weird. :-|
>>You are having a font encoding problem (at least 90% sure but you never
>>know for sure).
>>But, you would normally get a small square box rather than a blank when the
>>glyph isn't in the font.
> Yes, sometimes I see the square, but sometimes not (Luxi Sans for example does 
> not) ... :-(
I don't know what would cause that unless the font actually has the blank character for 
that character code.
>>Have you tried other fonts to see if you have the same problem?  That is
>>probably what I would try next.
>>As I said, some KDE applications let you set the encoding.  Did you try
>>this in KMail?
>>	View => Set Encoding
> Yes. Trying iso8859-15 or utf8 in this mail gives me the same result - no EUR 
> sign.
> Thinking about the _size_ behaviour described above, it seems that Qt selects 
> different fonts e.g. when the selected size is not natively (as bitmapped 
> font) available. Question is: what does it select then, and - is this a Qt 
> bug?

Qt has a font selection algorithm that scores the fonts and is supposed to select the best 
substitution.  If that fails, it will select the default font set in: "qtconfig" and the 
default there is Helvetica.
> When I run qtconfig and try the same font with different sizes, I also have 
> this problem - sometimes I see the EUR sometimes not, e.g.:
> Courier [Adobe], Normal
> 6,7,9,11 don't show EUR
> 8,10,12,14,16,18,20,22,24,26,28,36,48,72 are OK

As I said above, try the two Type1 Courier fonts that come with XFree86.

I note that I have also had problems with Qt and Courier.  I seems to get confused about 
which one to use.


This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list