DCOP KUniqueApplication error with ATI 3D accleration

Gerhard W. Gruber sparhawk at gmx.at
Sat Dec 6 19:21:32 GMT 2003

For the last week I have tried to activate the 3D acceleration for my Asus
Radeon 9800XT, but I had no luck so far.
I have installed the 3.2.8 driver for XFree86 4.3.0 and I activated DRM in the
kernel. I can load the agpgart module and fglrx successfully, but when I start
X then I get this error message:

DCOP aborting call from 'anonymous-3627' to 'kded'
ERROR: KUniqueApplication: DCOP communication error!
DCOP aborting call from 'anonymous-3630' to 'knotify'
ERROR: KUniqueApplication: DCOP communication error!
startkde: Shutting down...
KLauncher: Exiting on signal 1
startkde: Running shutdown scripts...
startkde: Done.

I tried to run fvmw2 and this one starts fine but when I try to run glxgears
it breaks with an error message. I assume that fvmw2 doesn't even touch 3D
while KDE might (then again it might not).
So I wonder how to get rid of thet problem.

My Kernel is 2.4.22 form kernel.org. I 'm running Suse Prof 8.0 with all
updates to 8.2 (libg and all that stuff) and KDE 3.1.

I already talked to the XFree people but they also couldn't help me and sait
it is probably a KDE issue.

When I startx then X starts up fine. I can move the mouse and see the gray
high-resolution screen, so this is not the problem. But after a few seconds,
when either the kdm loginscreen or the splashscreen from KDE (depending on how
I start X) X breaks with the above errormessage.

I also tried to use the KDE archive but I found no postings. Maybe I was using
the wrong search criteria, don't know.

Sombody pointe me to GATOS at sourceforge, but they wrote that work for Radeon
9700 is under way, so I guess my crd will not work with this either.

Form what I learned on the web it seems that many people got the Radeon 9800
Pro working. I don't think that thee is so much difference between 9800 Pro
and 9800 XT. AFAIK it may be only the memory and timing.

The poster in kde-devel said this is most probably an OpenGL issue but I still
don't know how to fix it.
Gerhard Gruber
Maintainer of
SoftICE for Linux - http://sourceforge.net/projects/pice
Fast application launcher - http://sourceforge.net/projects/launchmenu
This message is from the kde mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

More information about the kde mailing list