gramofile records nothing

Tom Kuiper tbhk at
Fri Aug 22 05:34:19 BST 2003

> From: Martin Fahrendorf <martin at>
> To: kde at
> Subject: Re: [kde] gramofile records nothing
> Date: Tue, 19 Aug 2003 20:09:36 +0200
> If you want to use krecord and the and you are tired of the dropouts,=20
> please look after a little programm called artswrapper. if you set=20
> this prorgram to siud root all the dropouts are gone. The reason is=20
> the realtime priority which currently only root can activate. And=20
> this has noting to do with the host performance. On my 400 MHz K6-3=20
> system all the recording works great.
Dear Martin,

On my system:

nutmeg:/home/kuiper# ls -l /usr/bin/artswrapper
-rwsr-xr-x    1 root     root         4000 Mar  1  2002 /usr/bin/artswrapper
nutmeg:/home/kuiper# /usr/bin/artswrapper -h
>> running as realtime process now (priority 50)
usage: /usr/bin/artsd [ options ]
nutmeg:/home/kuiper# ps ax | grep artsd
  542 ?        S      0:02 /usr/bin/artsd -F 9 -S 4096 -s 60 -m artsmessage -l 3 -f

So, I have what you describe, I think.  However, I just tried krecord again,
from the command line this time instead of the menu.  Still the same.
I tried running krecord as root but it is no better.  I notice that while
artswrapper is SUID root, artsd is not.  Could this be the problem?
nutmeg:/home/kuiper# ls -l /usr/bin/artsd
-rwxr-xr-x    1 root     root       117596 Mar  1  2002 /usr/bin/artsd

Besides the sound "skipping" I notice that the seconds (?) counter moves
faster than real-time during playback.  It seems to move irregularly during
recording, sometimes taking 3-4 seconds to update one unit.

Could it be necessary that I need to fine-tune the -F and -S options?  I tried
some of that with the Control Panel, without success.

There was also one diagnostic output from krecord:
Double QObject deletion detected.
Does it mean anything?

Best regards

This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list