Can't install KDE 3.1.3 on RedHat 9

Tron Thomas tron.thomas at
Mon Aug 11 02:20:51 BST 2003

I have upgraded from RedHat 7.2 to 9.0 on my Intel system.
RedHat 9 comes with version 3.1-11 of KDE.
I want to run the latest version (3.1.3 of KDE), and I am experiencing no end of 
grief in trying to do this.

Here is what I have tried:

First I downloaded all the RPM's for the KDE distribution on my system.
I tried to just rpm all the packages.  That didn't work.  I don't remember 
exactly what went wrong.  I think it was complaints about dependecies.

So, I then tired installing RPM's individually.  I got arts-1.1.3-0.9x.1 
installed.  I got arts-1.1.3-0.9x.1 installed.  I tried to install kdelibs.  
When I install the package, I get this error:

# rpm -Uvh kdelibs-3.1.3-0.9x.4.i386.rpm
error: Failed dependencies:
        kdelibs = 6:3.1-11 is needed by (installed) kdelibs-devel-3.1-11

If I try to upgrade kdelibs-devel first and this is what happens:
# rpm -Uvh kdelibs-devel-3.1.3-0.9x.4.i386.rpm
error: Failed dependencies:
        kdelibs = 6:3.1.3-0.9x.4 is needed by kdelibs-devel-3.1.3-0.9x.4

Well what the hell am I suppose to do about that?  This is a catch 22 situation. 
 I can install either package because they both depend on each other.  This 
is why I hate screwing around with stupid RPM files.  Trying to deal with 
all the dependency nonsense makes it impossible to accomplish anything.  You 
either don't have file that has the dependency and you have no idea how to find 
it, or you have my situation where you can't install because of cyclic 

I suppose I can force the installation of one of the packages.  I'm 
not sure if that would be a good idea.

Having given up on installing from RPM's, I decided to use the konstruct build 
tool to download, build and install the latest KDE version.  When I run make 
from the konstruct/meta/kde directory, and I get the following 

Making all in qtmcop
make[6]: Entering directory 
`/home/Tron/konstruct/libs/arts/work/arts-1.1.3/qtmcop'/bin/sh ../libtool 
--silent --mode=link --tag=CXX g++  -Wnon-virtual-dtor -Wno-long-long -Wundef 
-Wall -pedantic -W -Wpointer-arith -Wwrite-strings -ansi -D_XOPEN_SOURCE=500 
-D_BSD_SOURCE -Wcast-align -Wconversion -DNDEBUG -DNO_DEBUG -O2 
-I/home/Tron/kde3.1.3/include -I/usr/X11R6/include -L/home/Tron/kde3.1.3/lib 
-L/usr/X11R6/lib -O2 -pipe -I/home/Tron/kde3.1.3/include -I/usr/X11R6/include 
-L/home/Tron/kde3.1.3/lib -L/usr/X11R6/lib -O2 -pipe 
-I/home/Tron/kde3.1.3/include -I/usr/X11R6/include -L/home/Tron/kde3.1.3/lib 
-L/usr/X11R6/lib -O2 -pipe -I/home/Tron/kde3.1.3/include -I/usr/X11R6/include 
-L/home/Tron/kde3.1.3/lib -L/usr/X11R6/lib -O2 -pipe -fno-exceptions 
-fno-check-new  -ftemplate-depth-99   -L/home/Tron/kde3.1.3/lib -L/usr/X11R6/lib 
-L/home/Tron/kde3.1.3/lib -L/usr/X11R6/lib -L/home/Tron/kde3.1.3/lib 
-L/usr/X11R6/lib -L/home/Tron/kde3.1.3/lib -L/usr/X11R6/lib -o libqtmcop_la_closure.lo -no-undefined -version-info 1:0 -R 
/home/Tron/kde3.1.3/lib -R /home/Tron/kde3.1.3/lib -R /usr/X11R6/lib  
-L/home/Tron/kde3.1.3/lib -L/usr/X11R6/lib  qiomanager.lo ../mcop/ 
-lqt-mt  -lpng -lz -lm -lXext -lX11  -lSM -lICE -lpthreadlibtool: link: warning: 
`-version-info' is ignored for programs/home/Tron/kde3.1.3/lib/ 
undefined reference to `operator 
new(unsigned)@GLIBCPP_3.2'/home/Tron/kde3.1.3/lib/ undefined 
reference to `vtable for 
__cxxabiv1::__class_type_info at GLIBCPP_3.2'/home/Tron/kde3.1.3/lib/ 
undefined reference to `vtable for 
__cxxabiv1::__vmi_class_type_info at GLIBCPP_3.2'/home/Tron/kde3.1.3/lib/libqt-mt.s
o: undefined reference to `operator 
delete[](void*)@GLIBCPP_3.2'/home/Tron/kde3.1.3/lib/ undefined 
reference to `vtable for 
__cxxabiv1::__si_class_type_info at GLIBCPP_3.2'/home/Tron/kde3.1.3/lib/
: undefined reference to 
`__cxa_pure_virtual at CXXABI_1.2'/home/Tron/kde3.1.3/lib/ undefined 
reference to `operator 
new[](unsigned)@GLIBCPP_3.2'/home/Tron/kde3.1.3/lib/ undefined 
reference to `operator delete(void*)@GLIBCPP_3.2'
collect2: ld returned 1 exit status

So, what the hell is going on with this?  Why can't it resolve calls to 
operator new and operator delete?  I can write a program that explicity calls 
the global new and delete operators.  It compiles just fine.  I looked through 
the source code for this module and it wasn't doing anything but standar memory 
allocate with call the new operator.

Furthermore, what is this qtmcop module?  What is it for?  I thought maybe it 
was a component of Qt that construct built to support KDE.  I downloaded, built 
and installed the latest version of Qt.  Then modified the gar.config.mak file 
for konstruct to specify that I already had Qt installed.  This didn't help.  
konstruct still tries to build the qtmcop module and still produces the same 

So, what the hell do I have to do get KDE 3.1.3 installed on RedHat 9?

This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list